If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla crashes at startup.

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
critical
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Peter A Jonsson, Assigned: Samir Gehani)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
(No idea what component this belongs to, sorry). Pulled from CVS 10 minutes ago.
Removed ~/.mozilla, no ~/.netscape exists. Did a make distclean yesterday and
had the same crash. No arguments given to configure. Getting these assertions on
startup:

**************************************************
nsNativeComponentLoader:
SelfRegisterDll(/home/pj/moz2/mozilla/dist/bin/components/libgklayout.so) Load
FAILED with error: /home/pj/moz2/mozilla/dist/bin/components/libgklayout.so:
undefined symbol: 
nsBox::GetOrdinal(nsBoxLayoutState &, unsigned int &)
**************************************************
...
###!!! ASSERTION: ContentViewer Initialization failed: 'Error', file
nsDocShell.cpp, line 4409
Break: at file nsDocShell.cpp
###!!! ASSERTION: User did not call nsIContentViewer::Close: '!mDocument', file
nsDocumentViewer.cpp, line 1145
Break: at file nsDocumentViewer.cpp
WARNING: NS_ENSURE_TRUE(docShellElement) failed, file nsXULWindow.cpp, line 1099
WARNING: NS_ENSURE_TRUE(windowElement) failed, file nsXULWindow.cpp, line 1119
###!!! ASSERTION: ContentViewer Initialization failed: 'Error', file
nsDocShell.cpp, line 4409
Break: at file nsDocShell.cpp
###!!! ASSERTION: User did not call nsIContentViewer::Close: '!mDocument', file
nsDocumentViewer.cpp, line 1145
Break: at file nsDocumentViewer.cpp
/home/pj/moz2/mozilla/dist/bin/run-mozilla.sh: line 72:  1945 Segmentation fault
     $prog ${1+"$@"}

Stacktrace:

#0  0x414461a6 in nsXULPrototypeScript::Compile(unsigned short const*, int,
nsIURI*, int, nsIDocument*, nsIXULPrototypeDocument*) (this=0x8250048, 
    aText=0x82a2968, aTextLength=34, aURI=0x813de20, aLineNo=118, 
    aDocument=0x0, aPrototypeDocument=0x8264e18) at nsXULElement.cpp:5437
#1  0x41450211 in XULContentSinkImpl::HandleEndElement(unsigned short const*) (
    this=0x8299100, aName=0x829ad0c) at nsXULContentSink.cpp:946
#2  0x40d329f1 in nsExpatDriver::HandleEndElement(unsigned short const*) (
    this=0x8297680, aValue=0x829ad0c) at nsExpatDriver.cpp:344
#3  0x40d319eb in Driver_HandleEndElement(void*, char const*) (
    aUserData=0x8297680, aName=0x829ad0c "s") at nsExpatDriver.cpp:79
#4  0x40d5e4a4 in doContent (parser=0x829a8c8, startTagLevel=0, 
    enc=0x40d9b7e0, s=0x82aab1e "<", end=0x82abe9a "", nextPtr=0x829a8d4)
    at xmlparse.c:1502
#5  0x40d5d5b2 in contentProcessor (parser=0x829a8c8, start=0x82a9e60 "<", 
    end=0x82abe9a "", endPtr=0x829a8d4) at xmlparse.c:1106
#6  0x40d5d10e in XML_ParseBuffer (parser=0x829a8c8, len=8192, isFinal=0)
    at xmlparse.c:963
#7  0x40d5d074 in XML_Parse (parser=0x829a8c8, s=0x829e958 "n", len=8192, 
    isFinal=0) at xmlparse.c:953
#8  0x40d33ab3 in nsExpatDriver::ParseBuffer(char const*, unsigned, int) (
    this=0x8297680, aBuffer=0x829e958 "n", aLength=8192, aIsFinal=0)
    at nsExpatDriver.cpp:664
#9  0x40d33ea0 in nsExpatDriver::ConsumeToken(nsScanner&, int&) (
    this=0x8297680, aScanner=@0x8298700, aFlushTokens=@0xbffff348)
    at nsExpatDriver.cpp:772
#10 0x40d4de2d in nsParser::Tokenize(int) (this=0x82943b8, aIsFinalChunk=0)
    at nsParser.cpp:2512
#11 0x40d4bc84 in nsParser::ResumeParse(int, int, int) (this=0x82943b8, 
    allowIteration=1, aIsFinalChunk=0, aCanInterrupt=1) at nsParser.cpp:1736
#12 0x40d4d9c5 in nsParser::OnDataAvailable(nsIRequest*, nsISupports*,
nsIInputStream*, unsigned, unsigned) (this=0x82943b8, request=0x824abb0,
aContext=0x0, 
    pIStream=0x822d430, sourceOffset=0, aLength=16384) at nsParser.cpp:2371
#13 0x40e05f7d in nsDocumentOpenInfo::OnDataAvailable(nsIRequest*, nsISupports*,
nsIInputStream*, unsigned, unsigned) (this=0x8225b50, request=0x824abb0, 
    aCtxt=0x0, inStr=0x822d430, sourceOffset=0, count=16384)
    at nsURILoader.cpp:242
#14 0x40a75646 in nsJARChannel::OnDataAvailable(nsIRequest*, nsISupports*,
nsIInputStream*, unsigned, unsigned) (this=0x824abb0, jarCacheTransport=0x822d364, 
    context=0x0, inStr=0x822d430, sourceOffset=0, count=16384)
    at nsJARChannel.cpp:631
#15 0x40a18835 in nsOnDataAvailableEvent::HandleEvent() (this=0x8258d08)
    at nsStreamListenerProxy.cpp:192
#16 0x409fedd0 in nsARequestObserverEvent::HandlePLEvent(PLEvent*) (
    plev=0x8258d0c) at nsRequestObserverProxy.cpp:115
#17 0x4023b686 in PL_HandleEvent (self=0x8258d0c) at plevent.c:596
#18 0x4023be60 in PL_ProcessEventsBeforeID (aSelf=0x80f81d8, aID=135)
#19 0x40b8621c in processQueue(void*, void*) (aElement=0x80f81d8, aData=0x87)
    at nsAppShell.cpp:447
#20 0x401f443f in nsVoidArray::EnumerateForwards(int (*)(void*, void*), void*)
    (this=0x80e1ea8, aFunc=0x40b861f0 <processQueue(void*, void*)>, aData=0x87)
    at nsVoidArray.cpp:660
#21 0x40b86262 in nsAppShell::ProcessBeforeID(unsigned long) (aID=135)
    at nsAppShell.cpp:455
#22 0x40b9042a in handle_gdk_event(_GdkEvent*, void*) (event=0x82598b8, 
    data=0x0) at nsGtkEventHandler.cpp:924
#23 0x4049c673 in gdk_event_dispatch (source_data=0x0, 
    current_time=0xbffff770, user_data=0x0) at gdkevents.c:2139
#24 0x404c9856 in g_main_dispatch (dispatch_time=0xbffff770) at gmain.c:656
#25 0x404c9e33 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#26 0x404c9fac in g_main_run (loop=0x8259848) at gmain.c:935
#27 0x403e966b in gtk_main () at gtkmain.c:524
#28 0x40b85eb5 in nsAppShell::Run() (this=0x80e1e90) at nsAppShell.cpp:332
#29 0x40b2171e in nsAppShellService::Run() (this=0x8127700)
    at nsAppShellService.cpp:450
#30 0x0805d9ad in main1(int, char**, nsISupports*) (argc=2, argv=0xbffffa54, 
    nativeApp=0x0) at nsAppRunner.cpp:1456
#31 0x0805e62a in main (argc=2, argv=0xbffffa54) at nsAppRunner.cpp:1805
Do you see this if you build from a source tarball of the same vintage?  I'm
wondering if it's some bogus dependency thing, because others (including the
tinderboxes) aren't seeing it.

Updated

16 years ago
Severity: major → critical
Keywords: crash
(Reporter)

Comment 2

16 years ago
With a new tarball the crash goes away. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.