UNREADEBLE russian characters in input box (tag <INPUT>)

VERIFIED WORKSFORME

Status

()

Core
Internationalization
--
major
VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Dmitrij Teterja, Assigned: smontagu)

Tracking

({intl})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

This is very serious bug!
When you open the HTML page with input box firld, and write some russian
characters in it, you'll see just a BOTTOM HALF of each character - the russian
letters are shifted in one half of character size down. So, when you write
english,czech and then russian, the english and czech letters will stay OK, but
russian are shifted and it's HARD to RECOGNIZE what letters you wrote.

Reproducible: Always
Steps to Reproduce:
1.Open page http://www.rambler.ru
2.Write some russian characters in FIND/SEARCH field at the top of the page
3.You'll see just the top half of the characters

Actual Results:  Cannot recognize russian characters

Expected Results:  shift russian characters to the top of the input box

It happens in _every_ HTML page i've ever used: google, mozilla search -
everywhere. 
In <TEXTAREA> it works fine.
reporter (Dmitrij Teterja): can you reproduce this bug with a recent build of
mozilla (for example, 1.1beta)? if so, please comment again with details. if
not, please resolve this bug as WORKSFORME. thanks.
got mail from reporter, hat he can still reproduce it.
(Reporter)

Comment 3

16 years ago
In Mozilla relese 1.1 Gecko/20020826 the bug still remains. I use kernel
2.4.18-6mdk, Linux Mandrake 8.2, KDE 2.1. I use standart russian fonts, that
come with Mandrake distribution.

Comment 4

16 years ago
Works for me with Mozilla 1.2b build 2002101612, Mandrake Linux 9.0, Gnome2
Over to intl, but sounds like buggy fonts....
Assignee: sgehani → smontagu
Component: XP Apps → Internationalization
QA Contact: paw → ylong
(Reporter)

Comment 6

16 years ago
Seems like to be O.K. now. I've installed Mozilla 1.2.1 (Gecko/20021130). The
font is pretty spreaded now, but correctly lined up. (MD9,kernel 2.4.19-16mdk)

Comment 7

16 years ago
I don't know how to type russian characters, but it works for me when I
type/paste from some where else.
Keywords: intl
Marking worksforme per comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 9

15 years ago
Mark as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.