Closed Bug 1438788 Opened 2 years ago Closed 2 years ago

Remove broken and unused Passwordmanager from SeaMonkey

Categories

(SeaMonkey :: Passwords & Permissions, enhancement)

SeaMonkey 2.0 Branch
enhancement
Not set

Tracking

(seamonkey2.49esr fixed, seamonkey2.53 affected, seamonkey2.56 wontfix, seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey2.57
Tracking Status
seamonkey2.49esr --- fixed
seamonkey2.53 --- affected
seamonkey2.56 --- wontfix
seamonkey2.57esr --- fixed

People

(Reporter: frg, Assigned: frg)

References

()

Details

Attachments

(1 file)

This one is broken:

chrome://communicator/content/passwordManager.xul

We don't have most locales for it in the tree. It could never have worked for a long long time as far as I see.

The one from toolkit:
chrome://passwordmgr/content/passwordManager.xul
located in:
mozilla/toolkit/components/passwordmgr/content

still works fine. So we should just get rid of the bad one and only when/if the one in toolkit gets removed fork this one then.
[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: just dead code
Testing completed (on m-c, etc.): c-r 2.53
Risk to taking this patch (and alternatives if risky): trivial
String changes made by this patch: only removals with no direct l10n impact.
Attachment #8951541 - Flags: review?(stefanh)
Attachment #8951541 - Flags: approval-comm-esr52?
Attachment #8951541 - Flags: approval-comm-beta?
Attachment #8951541 - Flags: review?(stefanh) → review+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/4c4a6e0505ac
Remove unused and broken Password Manager in SeaMonkey. r=stefanh
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Seamonkey2.57
Comment on attachment 8951541 [details] [diff] [review]
1438788-removepasswordmanager.patch

a=me
Attachment #8951541 - Flags: approval-comm-esr52?
Attachment #8951541 - Flags: approval-comm-esr52+
Attachment #8951541 - Flags: approval-comm-beta?
Attachment #8951541 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.