Closed Bug 1438838 Opened 4 years ago Closed 2 years ago

download-svg-1[ce].html fails on windows 10 when running on new hardware

Categories

(Core :: ImageLib, defect, P3)

54 Branch
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: jmaher, Unassigned)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

you can see many failures when on try:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=38d33764c8fcb54a270518d63f2b596a4f4dde30&filter-searchStr=reftest

we are getting new hardware to run windows 10 tests on and the tests are failing.

adding fuzzy-if changes allows this to pass:
# RUN TESTS NOT AFFECTED BY DOWNSCALE-DURING-DECODE:
 # ==================================================
 fuzzy-if(skiaContent,14,416) fails-if(webrender) == downscale-svg-1a.html downscale-svg-1-ref.html?80
 fuzzy(80,468) == downscale-svg-1b.html downscale-svg-1-ref.html?72
-fuzzy-if(skiaContent,8,292) == downscale-svg-1c.html downscale-svg-1-ref.html?64
+fuzzy-if(/^Windows\x20NT\x2010\.0/.test(http.oscpu),1,62) fuzzy-if(skiaContent,8,292) == downscale-svg-1c.html downscale-svg-1-ref.html?64
 fuzzy(17,208) == downscale-svg-1d.html downscale-svg-1-ref.html?53
-fuzzy(78,216) fuzzy-if(skiaContent,110,181) == downscale-svg-1e.html downscale-svg-1-ref.html?40
+fuzzy(80,216) fuzzy-if(skiaContent,110,181) == downscale-svg-1e.html downscale-svg-1-ref.html?40
 fuzzy(51,90) fuzzy-if(skiaContent,142,77) == downscale-svg-1f.html downscale-svg-1-ref.html?24
Whiteboard: [gfx-noted]
Comment on attachment 8951595 [details] [diff] [review]
add fuzzy-if to get reftests green

I would like to fuzzy-if and leave this open until there are dev cycles to look into this
Attachment #8951595 - Flags: review?(gbrown)
Attachment #8951595 - Flags: review?(gbrown) → review+
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/343991da562a
download-svg-1[ce].html fails on windows 10. r=gbrown
Keywords: leave-open
The leave-open keyword is there and there is no activity for 6 months.
:aosmond, maybe it's time to close this bug?
Flags: needinfo?(aosmond)

The leave-open keyword is there and there is no activity for 6 months.
:aosmond, maybe it's time to close this bug?

Flags: needinfo?(aosmond)

The leave-open keyword is there and there is no activity for 6 months.
:aosmond, maybe it's time to close this bug?

Flags: needinfo?(aosmond)

It appears these changes are already in tree.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(aosmond)
Resolution: --- → INVALID
Keywords: leave-open

Err and I'm not going to investigate further I mean.

You need to log in before you can comment on or make changes to this bug.