Port Bug 1437040 "Remove synchronous Bookmarks::GetItemIndex" to SeaMonkey

RESOLVED FIXED in seamonkey2.58

Status

enhancement
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: frg, Assigned: frg)

Tracking

Trunk
seamonkey2.58
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.58 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

a year ago
Bug 1378089 needs to be fixed first.

The smart bookmarks code in nsSuiteGlue.js also uses this and needs a bigger upgrade for this.
(Assignee)

Comment 1

a year ago
places part first. 1:1 patch
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
(Assignee)

Comment 2

a year ago
Both patches need Bug 1378089 fixed first so not setting review.
(Assignee)

Updated

a year ago
Blocks: 942937
(Assignee)

Comment 3

a year ago
Rebased after Bug 1436605 landed.
Attachment #8953519 - Attachment is obsolete: true
(Assignee)

Comment 4

a year ago
Comment on attachment 8951971 [details] [diff] [review]
1439220-places-getItemIndex.patch

[Approval Request Comment]
Regression caused by (bug #): Bug 1437040 
User impact if declined: broken boookmarks 
Testing completed (on m-c, etc.): comm-beta
Risk to taking this patch (and alternatives if risky): --
String changes made by this patch: --
Attachment #8951971 - Flags: review?(iann_bugzilla)
Attachment #8951971 - Flags: approval-comm-beta?
(Assignee)

Comment 5

a year ago
Comment on attachment 8955776 [details] [diff] [review]
1439220-places-getItemIndex-glue.patch

[Approval Request Comment]
Regression caused by (bug #): Bug 1437040 
User impact if declined: broken boookmarks 
Testing completed (on m-c, etc.): comm-beta
Risk to taking this patch (and alternatives if risky): --
String changes made by this patch: --
Attachment #8955776 - Flags: review?(iann_bugzilla)
Attachment #8955776 - Flags: approval-comm-beta?

Comment 6

a year ago
Comment on attachment 8951971 [details] [diff] [review]
1439220-places-getItemIndex.patch

LGTM r/a=me
Attachment #8951971 - Flags: review?(iann_bugzilla)
Attachment #8951971 - Flags: review+
Attachment #8951971 - Flags: approval-comm-beta?
Attachment #8951971 - Flags: approval-comm-beta+

Comment 7

a year ago
Comment on attachment 8955776 [details] [diff] [review]
1439220-places-getItemIndex-glue.patch

LGTM r/a=me
Attachment #8955776 - Flags: review?(iann_bugzilla)
Attachment #8955776 - Flags: review+
Attachment #8955776 - Flags: approval-comm-beta?
Attachment #8955776 - Flags: approval-comm-beta+

Comment 8

a year ago
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/11ede8b087c1
Port Bug 1437040 "Remove synchronous Bookmarks::GetItemIndex" to SeaMonkey. r=IanN
https://hg.mozilla.org/comm-central/rev/06878aedff3f
Align smart bookmark initialisation with browser. r=IanN
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.