Closed Bug 1439296 Opened 2 years ago Closed 2 years ago

float and intrinsic width when img and source is present.

Categories

(Core :: Layout: Floats, defect, P3)

60 Branch
Unspecified
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1149357

People

(Reporter: karlcow, Unassigned)

References

()

Details

(Whiteboard: [webcompat])

This is a spin-off of the webcompat issue 
https://webcompat.com/issues/15165
https://webcompat.com/uploads/2018/1/9f5bcb19-6234-4274-9384-49272e3bddb6.jpg


The structure of the issue is:

<li>
  <a href="http://…">
    <picture>

      <!-- source with 3 images -->
      <source srcset="//rs.img.com.ua/crop?w=80&amp;h=60&amp;url=%2F%2Fbm.img.com.ua%2Fimg%2Fhp%2F3672588.jpg, 
                      //rs.img.com.ua/crop?w=160&amp;h=120&amp;url=%2F%2Fbm.img.com.ua%2Fimg%2Fhp%2F3672588.jpg 2x, 
                      //rs.img.com.ua/crop?w=240&amp;h=180&amp;url=%2F%2Fbm.img.com.ua%2Fimg%2Fhp%2F3672588.jpg 3x">

      <!-- 1 image 160px -->
      <img src="//rs.img.com.ua/crop?w=160&amp;h=120&amp;url=%2F%2Fbm.img.com.ua%2Fimg%2Fhp%2F3672588.jpg" alt="">
    </picture>
  </a>
  <div>
    <a href="…">…</a>
  </div>
</li>


li > a {
    float: left;
    margin-right: 10px;
}


"li > a" is
*  Chrome:   80px
*  Firefox: 160px
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149357
You need to log in before you can comment on or make changes to this bug.