[CSD] Wrong colour used for main panel tabs

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: jurf, Unassigned)

Tracking

(Blocks 1 bug)

59 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

a year ago
Posted image comparison.png
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20180130211649

Steps to reproduce:

The colour is far too dark, different to both the tab borders and the colour used in GTK+ HeaderBars.

See the screenshot for a comparison using Adwaita 3.26.
(Reporter)

Updated

a year ago
Blocks: gtktitlebar
Status: UNCONFIRMED → NEW
Component: Untriaged → Widget: Gtk
Ever confirmed: true
Product: Firefox → Core
The GtkHeaderBar background color is the same (244, 244, 244). Tabs has different colors because those are styled by Firefox itself - not sure if we can change tab color.
Summary: [CSD] Wrong colour used for main panel border → [CSD] Wrong colour used for main panel tabs
Posted image screenshot
I think the problem is not in the color of tabs, but in the shadow at the bottom of the tab strip. On the screenshot left without CSD, right with CSD.
(Reporter)

Comment 3

a year ago
> I think the problem is not in the color of tabs, but in the shadow at the bottom of the tab strip. On the screenshot left without CSD, right with CSD.

Yes, exactly.
(Reporter)

Comment 4

a year ago
I think I found the culprit – looks like there are two transparent borders overlapping each other. Also, the newest patch didn’t fix the issue for the drag space basically being enabled all the time on Adwaita.
(In reply to Juraj Fiala from comment #4)
> Created attachment 8952367 [details]
> screenshot with extra drag space enabled
> 
> I think I found the culprit – looks like there are two transparent borders
> overlapping each other. Also, the newest patch didn’t fix the issue for the
> drag space basically being enabled all the time on Adwaita.

That's solved at Bug 1434621
(In reply to Juraj Fiala from comment #4)
> Created attachment 8952367 [details]
> screenshot with extra drag space enabled
> 
> I think I found the culprit – looks like there are two transparent borders
> overlapping each other. Also, the newest patch didn’t fix the issue for the
> drag space basically being enabled all the time on Adwaita.

Filed Bug 1439834 for it as Bug 1434621 has only a partial fix.
Depends on: 1439834
Please check if it's fixed after Bug 1439834 land.
Flags: needinfo?(jurf)
Closing per #7, please reopen if you still see that.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Flags: needinfo?(jurf)
You need to log in before you can comment on or make changes to this bug.