Open Bug 1439486 Opened 2 years ago Updated 2 years ago

[wpt-sync] Sync PR 6596 - Restrict notifications to secure top-level contexts.

Categories

(Testing :: web-platform-tests, enhancement, P3)

enhancement

Tracking

(Not tracked)

People

(Reporter: mozilla.org, Unassigned)

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 6596 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/w3c/web-platform-tests/pull/6596
Details from upstream follow.

Dominick Ng wrote:
>  Restrict notifications to secure top-level contexts.
>  
>  This change migrates the notifications tests to use HTTPS. It also adds
>  new tests to ensure that permission cannot be requested from insecure or
>  non-top-level contexts.
>  
>  This is in line with Google Chrome's move to block notifications permission from being requested in [insecure](https://www.chromestatus.com/feature/5759967025954816) and [non-top-level contexts](https://www.chromestatus.com/feature/6451284559265792) as of version 61. A change to the Notifications API spec will also be filed once these tests are accepted.
>  
>  
>
Whiteboard: [wptsync downstream] → [wptsync downstream error]
Whiteboard: [wptsync downstream error] → [wptsync downstream]
Whiteboard: [wptsync downstream] → [wptsync downstream error]
Whiteboard: [wptsync downstream error] → [wptsync downstream]
You need to log in before you can comment on or make changes to this bug.