Closed Bug 1439499 Opened 3 years ago Closed 3 years ago

Session restore at browser start on linux doesn't work

Categories

(Firefox :: Session Restore, defect)

58 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1301041

People

(Reporter: godeater, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20180207210535

Steps to reproduce:

Start firefox after logging in to new linux desktop session.


Actual results:

Firefox always complains it was unable to restore the previous browsing session automatically, and shows a window where you can choose to restore the session manually. Clicking this button always successfully restores the previous browsing session.


Expected results:

Firefox should just restore the session on its own.
Component: Untriaged → Session Restore
Hi Bryan, sorry for the late reply.

Firefox doesn't complain about not being able to _restore_ automatically, but it does show the message that I think you're talking about when it wasn't able to shutdown properly (i.e. its process was killed forcibly).
Now this is not something we can do much about, but we do have a bug on file that suggests to just restore the session automatically after a crash. I'll dupe your report to that request for you.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1301041
I think this is not a dupe of bug 1301041 which is about *always* showing the session restore dialog, regardless of a crash having occurred or not.

This bug here seems to suggest to *never* show the session restore dialog and just restore the full session even when a crash has occurred.
You need to log in before you can comment on or make changes to this bug.