[gtk] Do not start moving window instantly when mousedown on dragging area

RESOLVED DUPLICATE of bug 1455235

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1455235
a year ago
a year ago

People

(Reporter: jhorak, Assigned: jhorak)

Tracking

(Blocks 1 bug)

Trunk
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(firefox60 affected)

Details

(Assignee)

Description

a year ago
Currently when the mousedown event happens in the dragging area the gtk start to move the window instantly [1]. This could lead to accidental moving the window when user do the doubleclick to restore/maximize window. 

Since client side decoration has been introduced in the GTK the GTK apps does not start moving until mousemove event happens.

[1] https://searchfox.org/mozilla-central/rev/0c0ddaa7e859a2b76a56a0e2e9c0de88af166812/toolkit/modules/WindowDraggingUtils.jsm#68
(Assignee)

Updated

a year ago
Summary: Do not start moving when mousedown on dragging area → [gtk] Do not start moving window instantly when mousedown on dragging area
Fixed by 1455235
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1455235
You need to log in before you can comment on or make changes to this bug.