Closed Bug 1439565 Opened 2 years ago Closed 2 years ago

Update webrender to 8a19316a733a484bf9bafb8257e3008b1418bfe4

Categories

(Core :: Graphics: WebRender, enhancement, P3)

60 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [gfx-noted])

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1438892 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
I still haven't managed to reproduce the failures referenced above. However, I'm not sure it's related to that gradient patch now - there's several other tests in R4 that appear to only be failing in debug mode, and many of them don't have any gradients in them. I'll keep trying to reproduce locally and investigating tomorrow.
WR @ 3797d9c9c28f93738bb037cddadee6c1e72e85e0

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ddc8f978d3bfb1b75a40631486130ac10ba0ef38
https://treeherder.mozilla.org/#/jobs?repo=try&revision=dbae0fbb6808af8fbea75a00496bb2a39c5058a1

Green

WR @ 2d2d7b7f293eaac2b463fe0e61a7face9253053e

https://treeherder.mozilla.org/#/jobs?repo=try&revision=3c1d576ae6c701b62efc56619583b175c3898c84
https://treeherder.mozilla.org/#/jobs?repo=try&revision=3824fdb735b4606c76e8eb9d66a5f07a2f09cdb3

R4 debug linux failures, and windows opt reftest went red (also because there was an increase in failures, and it hit the max log size). From servo/webrender#2441 as Glenn noted above.

WR @ c7778751c13ebe40c562e174c19a0e95cdc6a895

https://treeherder.mozilla.org/#/jobs?repo=try&revision=44ecb718fc801aa29285d6e7513d657f01c1ccaf
https://treeherder.mozilla.org/#/jobs?repo=try&revision=61a2d800f8357868896171ed7e4c86e517c083ec

R4 linux failures have spread to opt as well. So I guess it's not specific to debug, but is likely a race condition that gets triggered more often on debug than opt.
WR @ 8a19316a733a484bf9bafb8257e3008b1418bfe4

https://treeherder.mozilla.org/#/jobs?repo=try&revision=f2c0d91c2fef35bea888505733b98c824c92110c
https://treeherder.mozilla.org/#/jobs?repo=try&revision=7a66762cfa379627de3f8f87f8c546b035c9ccb6

Bunch of fuzziness changes, from servo/webrender#2445. The only weird thing is the R4 one seems to be bimodal in that mostly it has 8924 pixels that are different, but sometimes it has only 8772. I can cover it with a fuzzy range but I'm worried it's masking some underlying nondeterminism that we should address.
There's a lot of aa-related failures which I assume come from https://github.com/servo/webrender/pull/2445 and some bigger differences that most likely come from async scene building. I did find at least one mistake in the async scene building code that may cause epochs to be delayed by one frame some of the time and could explain at least some of the issues here.
All the AA failures from #2445 were annotated in all the try pushes listed in comment 8. The orange there should be all from your async scene building stuff.

I'm going to do an update to just before your async scene stuff landed.
Alias: wr-future-update
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to 8a19316a733a484bf9bafb8257e3008b1418bfe4
Version: unspecified → 60 Branch
Comment on attachment 8953431 [details]
Bug 1439565 - Update webrender to commit 8a19316a733a484bf9bafb8257e3008b1418bfe4.

https://reviewboard.mozilla.org/r/222684/#review228648
Attachment #8953431 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8953432 [details]
Bug 1439565 - Update reftest annotations for changes in WR PR 2445.

https://reviewboard.mozilla.org/r/222686/#review228646
Attachment #8953432 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3a32ca63e380
Update webrender to commit 8a19316a733a484bf9bafb8257e3008b1418bfe4. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/5eb19c81c7fd
Update reftest annotations for changes in WR PR 2445. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/3a32ca63e380
https://hg.mozilla.org/mozilla-central/rev/5eb19c81c7fd
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.