disabled Navigator/Tab window if Download Manager on.

RESOLVED DUPLICATE of bug 21296

Status

SeaMonkey
Download & File Handling
RESOLVED DUPLICATE of bug 21296
16 years ago
4 years ago

People

(Reporter: Ericson Herbas, Assigned: Blake Ross)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
MaxOSX version of Mozilla v1.0r2

File --> New --> Navigator/Tab are disabled (even the key-commands don't work)
when:  the Download Manager window is the frontmost and is the only other window
that's open, and while downloading a file.

The only way around this is to 'minimalize' the window so that it parks in the
Doc below... now I can create a window/tab.

Comment 1

16 years ago
Confirmed using RC2. Choosing File/New/Navigator Tab while the Download Manager
is frontmost (and whether or not a download is underway) results in no action,
and the File menu remains highlighted.
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

16 years ago
this bug is still happening in 1.0 R3.

Comment 3

16 years ago
Confirmed on v1.0 (build 2002052918).
(Reporter)

Comment 4

16 years ago
Yes, it's still happeningin 1.0.  
There's more to it... the first time I control-click (right click too) on an
image to save it locally works, but the next time I click on another image to
save, there's no response to creating new window/tab, saving, or performing any
actions within a page. To go around this bug, I clicked on the desktop then
click back on that window... now it works! BUT, if the "download manager" window
is on "keep window open..." button is clicked (which forces the download manager
window to stay in the front most), then the bug is not there. I think there's an
invisible window or objects of it stll there when that "keep open" window is
unchecked, that's why I have to double-click many times, or click somewhere
else, then click back to get the window working. A very annoying bug.
QA Contact: sairuh → petersen

Comment 5

16 years ago
Possibly another dupe of bug 21296.

All of these stem from the same root cause -- the Mac menu bar "thinks
different" from (X or MS) Windows, and Mozilla's various subsidiary windows
(dialogs, managers, etc) don't work the way MacOS expects.

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 21296 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.