Closed Bug 1439694 Opened 2 years ago Closed 2 years ago

ImportError jsonschema when running talos locally

Categories

(Testing :: Talos, defect)

Version 3
defect
Not set

Tracking

(firefox60 fixed, firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox60 --- fixed
firefox61 --- fixed

People

(Reporter: Alex_Gaynor, Assigned: rwood)

References

Details

(Whiteboard: [PI:March])

Attachments

(1 file)

Steps to reproduce:

1) rm -rf obj-*/testing/talos-venv/ (or $OBJDIR) is for you
2) env MOZCONFIG=(pwd)/mozconfig-opt MOZ_UPLOAD_DIR=(pwd)/sync-profile ./mach talos-test --activeTests sessionrestore --geckoProfile --cycles=1 --tpcycles=1 - this will work cleanly, the virtualenv is created, jsonschema is installed, and works fine
3) env MOZCONFIG=(pwd)/mozconfig-opt MOZ_UPLOAD_DIR=(pwd)/sync-profile ./mach talos-test --activeTests sessionrestore --geckoProfile --cycles=1 --tpcycles=1 - (the same command) this fails like so:

[...]
13:55:43     INFO -  Thanks for running Talos locally. Results are in ['/Users/agaynor/projects/mozilla-central/testing/mozharness/build/local.json']
13:55:43     INFO - Return code: 0
13:55:43     INFO - Running post-action listener: _package_coverage_data
13:55:43     INFO - Running post-action listener: _resource_record_post_action
13:55:43     INFO - [mozharness: 2018-02-20 18:55:43.729577Z] Finished run-tests step (failed)
13:55:43    FATAL - Uncaught exception: Traceback (most recent call last):
13:55:43    FATAL -   File "/Users/agaynor/projects/mozilla-central/testing/mozharness/mozharness/base/script.py", line 2059, in run
13:55:43    FATAL -     self.run_action(action)
13:55:43    FATAL -   File "/Users/agaynor/projects/mozilla-central/testing/mozharness/mozharness/base/script.py", line 1998, in run_action
13:55:43    FATAL -     self._possibly_run_method(method_name, error_if_missing=True)
13:55:43    FATAL -   File "/Users/agaynor/projects/mozilla-central/testing/mozharness/mozharness/base/script.py", line 1938, in _possibly_run_method
13:55:43    FATAL -     return getattr(self, method_name)()
13:55:43    FATAL -   File "/Users/agaynor/projects/mozilla-central/testing/mozharness/mozharness/mozilla/testing/talos.py", line 730, in run_tests
13:55:43    FATAL -     self._validate_treeherder_data(parser)
13:55:43    FATAL -   File "/Users/agaynor/projects/mozilla-central/testing/mozharness/mozharness/mozilla/testing/talos.py", line 599, in _validate_treeherder_data
13:55:43    FATAL -     import jsonschema
13:55:43    FATAL -   File "/Users/agaynor/projects/mozilla-central/build/mach_bootstrap.py", line 363, in __call__
13:55:43    FATAL -     module = self._original_import(name, globals, locals, fromlist, level)
13:55:43    FATAL - ImportError: No module named jsonschema
13:55:43    FATAL - Running post_fatal callback...
13:55:43    FATAL - Exiting -1
13:55:43     INFO - Running post-run listener: _resource_record_post_run
13:55:43     INFO - Running post-run listener: _upload_blobber_files
13:55:43  WARNING - Blob upload gear skipped. Missing cmdline options.
13:55:43     INFO - Running post-run listener: copy_logs_to_upload_dir
13:55:43     INFO - Copying logs to upload dir...
Whiteboard: [PI:February]
Assignee: nobody → rwood
Status: NEW → ASSIGNED
Comment on attachment 8954186 [details]
Bug 1439694 - Fix jsonschema import error when running talos locally;

Cancelling the review, this solution doesn't work for tp6 since tp6 uses a different py3 venv
Attachment #8954186 - Flags: review?(jmaher)
Comment on attachment 8954186 [details]
Bug 1439694 - Fix jsonschema import error when running talos locally;

https://reviewboard.mozilla.org/r/223342/#review229992
Attachment #8954186 - Flags: review?(jmaher) → review+
Note: Don't land this until it's tested on the new moonshot hardware (which will be re-landing in Bug 1431161)
Depends on: 1431161
Comment 10 is a try push of this jsonschema patch but running on the new moonshot win10 h/w
Whiteboard: [PI:February] → [PI:March]
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f249c97b9d35
Fix jsonschema import error when running talos locally; r=jmaher
https://hg.mozilla.org/mozilla-central/rev/f249c97b9d35
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.