Closed Bug 1439772 Opened 4 years ago Closed 4 years ago

Assert.jsm should not truncate operands with Assert.deepEqual.

Categories

(Testing :: General, defect)

defect
Not set
normal

Tracking

(firefox60 fixed)

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: tcsc, Assigned: tcsc)

References

Details

Attachments

(1 file)

I've hit this a number of times, and it's annoying each time. Often enough the actual difference isn't included in the first 128 or so characters of JSON.stringify, and so you need to add a wrapper to Assert.deepEqual that outputs the entire JSON.stringify result on failure, or similar.

This is easy enough to fix, so patch incoming.
Comment on attachment 8952559 [details]
Bug 1439772 - Avoid truncating operands when reporting failure for Assert.deepEqual

https://reviewboard.mozilla.org/r/221802/#review227754

I think you're not the only one who finds this annoying, so r=me! Thanks for working on this!
Attachment #8952559 - Flags: review?(mdeboer) → review+
Pushed by tchiovoloni@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4a2e77d5fc7a
Avoid truncating operands when reporting failure for Assert.deepEqual r=mikedeboer
https://hg.mozilla.org/mozilla-central/rev/4a2e77d5fc7a
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Duplicate of this bug: 1375656
You need to log in before you can comment on or make changes to this bug.