All users were logged out of Bugzilla on October 13th, 2018

Crash: Encrypt Sensitive Information from Chatzilla

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: mozilla7, Assigned: morse)

Tracking

({crash})

Trunk
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051005

I have no idea how to read crash logs, so please file this as needed.

I don't have a master password set; not sure if that's relevant.

Reproducible: Always
Steps to Reproduce:
1. open Chatzilla
2. go to Tools/Password Manager/Encrypt Sensitive Information
3. at prompt to enter a new master password (since none is set), click Cancel


Actual Results:  Date/Time:  2002-05-12 14:58:07 -0700
OS Version: 10.1.4 (Build 5Q125)
Host:       sage.webwizardry.lan

Command:    Mozilla
PID:        2409

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
 #0   0x03df19bc in wallet_Alert(wchar_t *, nsIDOMWindowInternal *)
 #1   0x03df19b8 in wallet_Alert(wchar_t *, nsIDOMWindowInternal *)
 #2   0x03dfb8e8 in wallet_ReencryptAll(char const *, void *)
 #3   0x01ba4368 in pref_DoCallback(char const *)
 #4   0x01ba3cd4 in pref_HashPref(char const *, PrefValue, PrefType, PrefAction)
 #5   0x01ba293c in PREF_SetBoolPref
 #6   0x01b98494 in nsPrefBranch::SetBoolPref(char const *, int)
 #7   0x01ba15dc in nsPrefService::SetBoolPref(char const *, int)
 #8   0x005b9a0c in XPTC_InvokeByIndex
 #9   0x005b9900 in XPTC_InvokeByIndex
 #10  0x01d1a674 in 0x1d1a674
 #11  0x01d20b0c in XPC_WN_CallMethod(JSContext *, JSObject *, unsigned int,
long *, long *)
 #12  0x01c99afc in js_Invoke
 #13  0x01ca1ba4 in 0x1ca1ba4
 #14  0x01c99b54 in js_Invoke
 #15  0x01c99da0 in js_InternalInvoke
 #16  0x01c7ae6c in JS_CallFunctionValue
 #17  0x027dc33c in nsJSContext::CallEventHandler(void *, void *, unsigned int,
void *, int *, int)
 #18  0x027fbb74 in nsJSEventListener::HandleEvent(nsIDOMEvent *)
 #19  0x02351a40 in HandleEventSubType__22nsEventListenerManagerFP16nsListenerStru
 #20  0x02354080 in HandleEvent__22nsEventListenerManagerFP14nsIPresConte
 #21  0x0258f704 in HandleDOMEvent__12nsXULElementFP14nsIPresContextP7nsEventPP11n
 #22  0x01febb70 in DispatchCommandTo__12MenuHelpersXFP16nsIWeakReferenceP10nsICon
 #23  0x01ff2d3c in nsMenuItemX::DoCommand(void)
 #24  0x01fe8fec in nsMenuBarX::CommandEventHandler(OpaqueEventHandlerCallRef *)
 #25  0x73118b08 in DispatchEventToHandlers
 #26  0x73101d98 in SendEventToEventTargetInternal
 #27  0x731b65b8 in SendEventToEventTarget
 #28  0x7310ba6c in SendHICommandEvent
 #29  0x731a81cc in SendMenuItemSelectedEvent
 #30  0x7318b54c in FinishMenuSelection(OpaqueMenuHandle *, MenuResult *,
MenuResult *, unsigned long)
 #31  0x731655e0 in MenuSelectCore(Point, double, unsigned long,
OpaqueMenuHandle **, unsigned short *)
 #32  0x73187dd4 in MenuSelect
 #33  0x01fd0f00 in 0x1fd0f00
 #34  0x01fd0b9c in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #35  0x01fd09c0 in nsMacMessagePump::DoMessagePump(void)
 #36  0x01fd033c in nsAppShell::Run(void)
 #37  0x01ef6bcc in nsAppShellService::Run(void)
 #38  0x004c9ddc in main1(int, char **, nsISupports *)
 #39  0x004ca81c in main

Thread 1:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x70283ea4 in TSWaitOnConditionTimedRelative
 #3   0x7027d748 in TSWaitOnSemaphoreCommon
 #4   0x702c2078 in TimerThread
 #5   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250ab0 in TSWaitOnCondition
 #3   0x7027d730 in TSWaitOnSemaphoreCommon
 #4   0x70243d14 in AsyncFileThread
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002054c in _pthread_body

Thread 6:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body

PPC Thread State:
  srr0: 0x03df19bc srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x00000020   lr: 0x03df19b8  ctr: 0x006188d0   mq: 0x00000000
    r0: 0x03df19b8   r1: 0xbfffd8a0   r2: 0x03ae7000   r3: 0xbfffd8d8
    r4: 0x00000000   r5: 0xbfffd924   r6: 0x00000000   r7: 0x03c4e0cc
    r8: 0x00000005   r9: 0x80240e10  r10: 0x00000024  r11: 0x80003710
   r12: 0x000ff7bc  r13: 0x03c7d940  r14: 0x01b88a68  r15: 0x00000006
   r16: 0x01e7b2c0  r17: 0x00000000  r18: 0x00000002  r19: 0x00000002
   r20: 0xbfffded8  r21: 0x03c4e0d0  r22: 0x00000000  r23: 0x00000000
   r24: 0x00000000  r25: 0x00000000  r26: 0x00000000  r27: 0x00000000
   r28: 0x00000080  r29: 0x00000000  r30: 0x00000000  r31: 0x03c4e0d0

**********


Expected Results:  Alert, "Unable to convert stored data."  I'm not sure what
that really means, but that's what happens when doing the same thing from
Navigator instead of Chatzilla.
-> Password Manager
Assignee: Matti → morse
Component: Browser-General → Password Manager
Keywords: crash
QA Contact: imajes-qa → tpreston
(Assignee)

Comment 2

17 years ago
This is working fine for me, using the latest trunk build.  Of course on the 
trunk build you can't get to "encrypt sensitive information" from the tools menu 
but instead must use the password-manager subpanel of the prefs panel.

Terri, can you reproduce this on the trunk?  On the branch?
(Reporter)

Comment 3

17 years ago
Also confirmed crash in Linux 2002051009:
/usr/local/mozilla/run-mozilla.sh: line 72: 13283 Segmentation fault      $prog
${1+"$@"}

It's crashing from Chatzilla and Address Book, but not from Navigator or
Messenger or Composer.

Comment 4

17 years ago
yes, morse I can reproduce on windows branch 20020512, marking new, talkback id
is  6242533   
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

17 years ago
Terri, can you reproduce it on the trunk?
(Assignee)

Comment 6

17 years ago
Also, is this reproducible in win32 or is it mac/linux only?

Comment 7

17 years ago
I crashed on Windows morse, there is no option for encrypt on trunk build
2002051308, so I can't reproduce on trunk (when i try using encryption in
Preferences, i do not crash)
(Assignee)

Comment 8

17 years ago
That's correct -- the encryption has moved from the tools menu to the pref panel 
(see my comment 2).  So from what you are saying, it appears to have been broken 
on the branch but has since been fixed on the trunk.  I have no idea what 
checkin would have fixed it.

Changin OS to all based on comments 3 and 7
Status: NEW → ASSIGNED
OS: MacOS X → All
(Assignee)

Comment 9

17 years ago
I just went to an old build that I had lying around (before the menu changes) 
and was able to reproduce it.  So in that build I tried doing it from the pref 
panel.  In that case there was no crash.

So the bug has in essense been fixed by the fact that we no longer set the 
master password from the menu directly.  I don't understand what was causing 
the crash before, but at least we now know that the bug is obsolete.  By that I 
mean that it will not be present in either the final netscape or mozilla 
product because they will use the new menu structure.

Therefore I'm closing this out as works-for-me since it will work in the final 
products.  If mistaken and the the final products will not use the new menu 
structure, then reopen this bug and I'll investigate further.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Hardware: Macintosh → All
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.