Closed Bug 1439826 Opened 4 years ago Closed 4 years ago

[wpt-sync] Sync PR 9596 - cc Add https://streams.spec.whatwg.org/demos tests

Categories

(Testing :: web-platform-tests, enhancement, P3)

enhancement

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: mozilla.org, Unassigned)

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 9596 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/w3c/web-platform-tests/pull/9596
Details from upstream follow.

Michael[tm] Smith wrote:
>  cc Add https://streams.spec.whatwg.org/demos tests
>  
>  When JavaScript-syntax checking for `script`-element contents was
>  recently added to the HTML checker, it broke the build of the Streams
>  spec due to some documents in https://streams.spec.whatwg.org/demos/
>  using some newer JavaScript syntax that the Rhino parser (which the HTML
>  checker relies on) doesn’t understand yet.
>  
>  So to ensure those cases get handled correctly, some refinements were
>  made to the HTML checker and the Rhino fork it uses. The documents are
>  added here to ensure no regressions occur.
>  
>  Thanks @domenic
https://hg.mozilla.org/mozilla-central/rev/f88927b778ca
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.