If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

System slow down / freeze after some time of using Mozilla

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: -, Assigned: Matti)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002050106

After working with mozilla for some time (I notified ranges between 2 and 4
hours up to now) the system(!) starts to slow down. This slow down isn't
constant (it could belong to the way I was working with mozilla).
Once I could watch this slow-down lasting over 30 minutes from the first
notification up to the point where I had to restart windows (this worked normaly
in that case).
The last one was 'faster': just less than 5 minutes, then I had to
'[Ctrl][Alt][Del]' twice! The system didn't bring up the Task-Manager for more
than 3 minutes after the first one! But the second [Ctrl][Alt][Del] produced a
'normal' warm-boot (no scandisc after the reboot!).
I notified a strange mouse-behaviour too: the longer the slow-down lasts, the
more the mouse starts moving like beeing moved over rubber! This is a bit
strange because even when I had a not reacting (is this a correct word?)
explorer, the mouse kept to move normaly!

When I notified this slow-down, CPU-Idle shows up an growing system-load even
while mozilla (and the rest of the system) should be idle (pages are loaded
completely!) up to over 80% on an Athlon XP-1700 with 512MB RAM! (Now at the
moment it is less than 1% system-load at all!)

In the first case I checked the Task-Manager (it came up normaly that time) and
found no unusual entry. But I could *imagine* something like 'ghost-threads' or
anything like this. See c't 8/2002, pg. 43 (ISSN 0724-8679) to understand what
I'm thinking about.

Of course you can tell me what to do to find out more?
And: sorry for my bad english. Don't be afraid to correct me or to ask if you
don't understand anything!


Reproducible: Sometimes
Steps to Reproduce:
I can't help you with this because I can't really tell you *when* this will
happen. Sorry!
I just know: it happens. But I got no crystal bowl so I can't tell you more ;-)

The most of the 'working time' I've been talking above I've been on the 'Heise
News Forum' (http://www.heise.de/foren/), reading and posting something. Of
course the dialogs there make a problem? On this pages I often get a blank page
when mozilla says 'ready' so I have to reload - sometimes two, three or more
times - to get the real contents!

Comment 1

16 years ago
Reporter, could you try to run the WinME Resource Meter (Start -> Programs ->
Accessories -> System Tools -> Resource Meter on English WinME) when this happens?
(Reporter)

Comment 2

16 years ago
Hello!

I just did what you asked for and I got some informations!

First: there is a problem while running the Alert Tracker from Norton PFW. If it
is active the System- and User- Resources keep swapping like water on the sea at
a stormy day! And they were synchronous, both levels were just the same. They
often broke down below 10%. The GDI-Resources didn't change at all!
When the Resources were down (let's say at 3%) it lasted about 20s until they
'relaxed' and came bak to 48%.
So I can imagine the problem: some pages I visited I just had to look on for
about an half or one second...

Having found this I deactivated the Alert Tracker - and now:

Second: The system looks like it is stable - but only on the first view. If I'm
switching around the web I feel like there is a problem with the GDI-Ressources
now. The System- and User-Resources aren't synchronous now. They don't differ
very much, but they do (sometimes).
After about 2 hours the GDI-counter went down for about 4%. By terminating
Mozilla the levels return to the start values. I can't decide if this is normal
and I'm afraid I can't surf around long enough to see the 63% (GDI-level now.
Before starting Mozilla this was about 73%) vanish (or, cf course, not).

So I think it would be a good idea to contact Norton. But before doing this I
will wait for your response.


Thanks! And have a lot of good bytes ;-)
Franz
(Reporter)

Comment 3

16 years ago
Hello, I'm back again.

Yes, there seems to be a resource-problem in mozilla RC2 (Build 2002051006).
After surfing the whole evening yesterday the system resources were fully down
and the windows-shell *and* mozilla started to display 'funny' things.
Mozilla didn't render the full page I had requested. Instead of this it only
took parts (for example an image) and rendered it as if this part would be the
full page. And windows forgot 'MARLET.TTF' and so the display looked strange
(the font was replaced by some other). And: the windows start menu came up only
very slowly and - in parts - only on the places where I moved my mouse over. I
had to restart windows to solve this.
After the restart of windows all looks fine - but the resources keep to vanish.

Could this be some kind of strange interaction between mozilla and the firewall?

*****

Ooops! Now I'm doing this form again! Reason: as I hit the Commit-Button the
first time I got a blue screen. It belonged to SYMVXD.VXD (part of the firewall).
This problem I had with one of the first Netscape 6 versions, but I didn't see
it for some time. Of course it is back now?

Comment 4

16 years ago
> Instead of this it only took parts (for example an image) and rendered
> it as if this part would be the full page. And windows forgot 'MARLET.TTF'
> and so the display looked strange (the font was replaced by some other).
> And: the windows start menu came up only very slowly and - in parts - only
> on the places where I moved my mouse over. I had to restart windows to
> solve this.

These are all symptoms of low system resources available. Unfortunately, it's
hard to nail down what causes the resource leak, as it happens gradually over a
period of tens of minutes or hours.

If you could find a page or method which repeatably causes the leak, that would
be great. I have not had much success in doing so.

1.0 RC1 was much worse though, at least for me, and was unusable after about 30
minutes of browsing. Maybe general cleanups are helping this.
(Reporter)

Comment 5

16 years ago
I understand the problem - how to fix a hole if it is hiding like a rabbit? I
can not see anything special (like extra large images) making the problem coming
up faster. But you could be right if you think about distinct pages: in fact I
got a feeling th problems are more present if I am working on
<http://www.heise.de/ct/>-pages. The most time I'm there I uses the forum pages
(like them you can find on <http://www.heise.de/newsticker/> or
<http://www.heise.de/ct/foren/go.shtml?list=1&forum_id=2>) where I read and
write many entries. I often keep 'scrolling' through the threads (open one, read
some top entries, go down the tree, go up again, write something and so on).

I hope this will help you a bit! I hope so because I like smiling faces -
smiling faces from mozilla users are wellcome, and from mozilla programmers too!

Franz

Comment 6

16 years ago
I have never been hit with resource leaks with 1.0 RC3. Reporter, shall we mark
this as worksforme or can you still see it?
(Reporter)

Comment 7

16 years ago
I just had a little 'ride' over my standard-sites.
The result ist: the resources don't run up and down wild now. Good!
But they seem to vanish (very) slowly. I think this is some effect from tabbed
browsing. I'm not quite sure, but if I open some tabs (for example: having an
index page, where you select 'your' themes at once), this seems to eat them up.
Just in the moment I tried it. I opened 2 tabs and closed them. Now I've got 50%
user-resources. They had been 51% on the begining.

Franz
(Assignee)

Comment 8

15 years ago
I can't reproduce this with build 20020804 and also 1.1b

marking worksforme

Please reopen if you can more informations (what is leaking etc.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.