Cannot rebuild Mozilla1.0rc2 .src.rpm

VERIFIED WONTFIX

Status

SeaMonkey
Build Config
VERIFIED WONTFIX
16 years ago
13 years ago

People

(Reporter: Emmanuel Seyman, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Building the .src.rpm of Mozilla 1.0rc2 on Zoot (RHL 6.2) fails with this error:

Patch #10 (mozilla-redhat-home-page-6.2.patch):
+ patch -p1 -s
2 out of 3 hunks FAILED -- saving rejects to
xpfe/browser/resources/locale/en-US/region.properties.rej
error: Bad exit status from /var/tmp/rpm-tmp.11827 (%prep)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.11827 (%prep)

This happens with locale set to en_US or fr_FR so it doesn't look locale-specific

Comment 1

16 years ago
==> Blizzard
Assignee: dveditz → blizzard
Component: Installer → Build Config

Updated

16 years ago
QA Contact: bugzilla → ktrina

Comment 2

16 years ago
really reassign
Assignee: blizzard → seawood
QA Contact: ktrina → granrose
patch problem with the rpm --> blizzard
Assignee: seawood → blizzard

Comment 4

16 years ago
it looks like the homepage patches just need the "/1.0/".

Comment 5

16 years ago
Created attachment 84304 [details] [diff] [review]
New RedHat 6.2 home page patch

This patch has the '1.0/' added to paths so it works.

Comment 6

16 years ago
marking NEW
nominating for 1.0

note that this occurs with both home page patches (normal and 6.2)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: mozilla1.0
Summary: Cannot rebuild Mozilla1.0rc2 .src.rpm on Red Hat 6.2 → Cannot rebuild Mozilla1.0rc2 .src.rpm
(Reporter)

Comment 7

16 years ago
Replacing the mozilla-redhat-home-page-6.2 patch in 1.0rc2 with Richard's fixes
the problem.
The .src.rpm compiles on RHL 6.2

Comment 8

16 years ago
The same new patch fixes the rc3 rpm build.

Comment 9

16 years ago
*** Bug 146640 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

16 years ago
Building 1.0rc3 fails with the same error (as described in #146640).
Applying the patch makes the build fail with this message:

nsFileStream.cpp
../../dist/include/string/nsAFlatString.h: In function `(static initializers for
../../dist/include/string/nsBufferHandle.h)':
../../dist/include/string/nsAFlatString.h:70: Internal compiler error 40.
../../dist/include/string/nsAFlatString.h:70: Please submit a full bug report to
`egcs-bugs@egcs.cygnus.com'.
../../dist/include/string/nsAFlatString.h:70: See
<URL:http://egcs.cygnus.com/faq.html#bugreport> for details.

In the directory  /usr/src/redhat/BUILD/mozilla/xpcom/io
The following command failed to execute properly:
c++ -o nsFileStream.o -c -DOSTYPE="Linux2.2.19-6.2" -DOSARCH="Linux" -DOJI
-D_IMPL_NS_COM -D_IMPL_NS_BASE -D_BSD_SOURCE -I../../dist/include/uconv
-I../../dist/inclu
de/string -I../../dist/include/xpcom -I../../dist/include
-I/usr/src/redhat/BUILD/mozilla/dist/include/nspr -I/usr/X11R6/include -fPIC
-I/usr/X11R6/include -fno-rtti
 -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wbad-function-cast
-Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -pedantic
-Wno-long-long -pt
hread -pipe -DNDEBUG -DTRIMMED -O -I/usr/X11R6/include -DMOZILLA_CLIENT -include
../../config-defs.h -Wp,-MD,.deps/nsFileStream.pp nsFileStream.cpp
make[3]: *** [nsFileStream.o] Error 1
make[2]: *** [libs] Error 2
make[1]: *** [tier_9] Error 2
make: *** [default] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.20302 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.20302 (%build)

Comment 11

16 years ago
> Internal compiler error 40

that's a compiler bug that is not related to this bug, and almost certainly not
even a Mozilla bug.

Comment 12

15 years ago
This issue may have been resolved, I havn't had any problems building more
recent versions of the rpm.

Comment 13

15 years ago
this still exists on the 1.0 branch (current CVS)
(Assignee)

Comment 14

15 years ago
Yeah, but I'm not going to check in the spec files on the 1.0 branch at this point.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 15

15 years ago
v wontfix.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.