Closed Bug 1440226 Opened 4 years ago Closed 4 years ago

[MIPS64] Fix Baseline stack alignment asserts.

Categories

(Core :: JavaScript Engine: JIT, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: dragan.mladjenovic, Assigned: dragan.mladjenovic)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.106 Safari/537.36
Attached patch bug1440226.patchSplinter Review
This patch replaces MacroAssembler::checkStackAlignment() calls on few baseline codepaths which assert on mips64. The MacroAssembler::checkStackAlignment() seems to be used inconsistently to assert both jit stack alignment and native ABI stack alignment (16-byte on mips64). Its does nothing on x86/x64 and for ARM64 it enforces 8-byte alignment.
Either way baseline does not provide more than 8-byte alignment on these codepaths so they are replaced with 8-byte stack alignment asserts.
Attachment #8952969 - Flags: review?(jdemooij)
Attachment #8952969 - Flags: review?(jdemooij) → review+
Keywords: checkin-needed
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/mozilla-inbound/rev/311e10f7befb
[MIPS64] Fix Baseline stack alignment asserts ; r=jandem
Keywords: checkin-needed
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5
https://hg.mozilla.org/mozilla-central/rev/311e10f7befb
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Assignee: nobody → dragan.mladjenovic
You need to log in before you can comment on or make changes to this bug.