Closed Bug 1440253 Opened 4 years ago Closed 3 years ago

Port bug 1440039 "Remove nsIDOMCanvasRenderingContext2D" to SeaMonkey

Categories

(SeaMonkey :: OS Integration, task)

task
Not set
normal

Tracking

(seamonkey2.49esr fixed, seamonkey2.53 fixed, seamonkey2.57esr fixed, seamonkey2.58 wontfix, seamonkey2.59 fixed)

RESOLVED FIXED
seamonkey2.59
Tracking Status
seamonkey2.49esr --- fixed
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed
seamonkey2.58 --- wontfix
seamonkey2.59 --- fixed

People

(Reporter: frg, Assigned: frg)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1440039 +++

It's unimplemented (since bug 800556), has only constants, the only JS user looks like dead code:

https://searchfox.org/mozilla-central/source/browser/modules/WindowsPreviewPerTab.jsm#346
[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Just dead code which comsumes some resources.
Testing completed (on m-c, etc.): c-esr52
Risk to taking this patch (and alternatives if risky): trivial
String changes made by this patch: --
Attachment #8976802 - Flags: review?(iann_bugzilla)
Attachment #8976802 - Flags: approval-comm-esr60?
Attachment #8976802 - Flags: approval-comm-esr52?
Comment on attachment 8976802 [details] [diff] [review]
1440253-nsIDOMCanvasRenderingContext2D.patch

LGTM r/a=me
Attachment #8976802 - Flags: review?(iann_bugzilla)
Attachment #8976802 - Flags: review+
Attachment #8976802 - Flags: approval-comm-esr60?
Attachment #8976802 - Flags: approval-comm-esr60+
Attachment #8976802 - Flags: approval-comm-esr52?
Attachment #8976802 - Flags: approval-comm-esr52+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/d086253f5f41
Remove unused nsIDOMCanvasRenderingContext2D. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Drat forgot the qrefresh and because nothing was in the patch couldn't backout. So just take 2.

https://hg.mozilla.org/releases/comm-esr52/rev/c4c59170a9a3efe8009064e2de9b634fa503353c
Comment on attachment 8976802 [details] [diff] [review]
1440253-nsIDOMCanvasRenderingContext2D.patch

Needed for backports. Already in unofficial version.
Attachment #8976802 - Flags: approval-comm-release+
Type: enhancement → task
You need to log in before you can comment on or make changes to this bug.