If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

appending to stream freezes application

RESOLVED WORKSFORME

Status

Core Graveyard
Embedding: GTK Widget
--
critical
RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: Vadim Berezniker, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I have an application where I continously append data to embedded gecko via a
stream. 
Recently, appending data freezes geck on the first append.
Even running TestGtkEmbed and using 'Test Stream' hangs TestGtkEmbed.
(Assignee)

Comment 1

16 years ago
Sounds like someone regressed something.  The embedding code hasn't changed.
(Assignee)

Comment 2

16 years ago
Hmmm...I can't reproduce this with either my 1.0 build or my tip build.  What
version are you using?
(Assignee)

Comment 3

16 years ago
Reducing to critical since I can't reproduce it.
Severity: blocker → critical
(Reporter)

Comment 4

16 years ago
This was a pull from trunk probably couple of hours before I filed this bug report.
#0  0x404a0b7a in sigsuspend () from /lib/libc.so.6
#1  0x405bd679 in __pthread_wait_for_restart_signal ()
   from /lib/libpthread.so.0
#2  0x405b9239 in pthread_cond_wait () from /lib/libpthread.so.0
#3  0x40163125 in PR_WaitCondVar ()
   from /mnt/bigdrive/mozilla/opt/dist/lib/libnspr4.so
#4  0x40163bac in PR_Wait ()
   from /mnt/bigdrive/mozilla/opt/dist/lib/libnspr4.so
#5  0x400c7b87 in nsPipe::nsPipeOutputStream::Flush() ()
   from /mnt/bigdrive/mozilla/opt/dist/lib/libxpcom.so
#6  0x400291fc in EmbedStream::AppendToStream(char const*, int) ()
   from /mnt/bigdrive/mozilla/opt/dist/lib/libgtkembedmoz.so
#7  0x40024b2f in EmbedPrivate::AppendToStream(char const*, int) ()
   from /mnt/bigdrive/mozilla/opt/dist/lib/libgtkembedmoz.so
#8  0x400225f3 in gtk_moz_embed_append_data ()
   from /mnt/bigdrive/mozilla/opt/dist/lib/libgtkembedmoz.so
#9  0x0804bcff in menu_stream_cb(_GtkMenuItem*, _TestGtkBrowser*) (
    menuitem=0x8078360, browser=0x8075cd8) at gaim.cpp:720
#10 0x40208c86 in gtk_marshal_NONE__NONE () from /usr/lib/libgtk-1.2.so.0
#11 0x4022e6f8 in gtk_signal_connect_object_after ()
   from /usr/lib/libgtk-1.2.so.0
#12 0x4022e2cd in gtk_signal_connect_object_after ()
   from /usr/lib/libgtk-1.2.so.0
---Type <return> to continue, or q <return> to quit---
#13 0x4022cf9f in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#14 0x4025a2ff in gtk_widget_activate () from /usr/lib/libgtk-1.2.so.0
#15 0x4020ebcc in gtk_menu_shell_activate_item () from /usr/lib/libgtk-1.2.so.0
#16 0x4020e63a in gtk_menu_shell_insert () from /usr/lib/libgtk-1.2.so.0
#17 0x4020883e in gtk_marshal_BOOL__POINTER () from /usr/lib/libgtk-1.2.so.0
#18 0x4022e30b in gtk_signal_connect_object_after ()
   from /usr/lib/libgtk-1.2.so.0
#19 0x4022cf9f in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#20 0x4025a21c in gtk_widget_event () from /usr/lib/libgtk-1.2.so.0
#21 0x40207aa5 in gtk_propagate_event () from /usr/lib/libgtk-1.2.so.0
#22 0x402076ce in gtk_main_do_event () from /usr/lib/libgtk-1.2.so.0
#23 0x4083f59a in handle_gdk_event(_GdkEvent*, void*) ()
   from /mnt/bigdrive/mozilla/opt/dist/bin/components/libwidget_gtk.so
#24 0x4028e63c in gdk_compress_exposures () from /usr/lib/libgdk-1.2.so.0
#25 0x402beef8 in g_source_remove_by_funcs_user_data ()
   from /usr/lib/libglib-1.2.so.0
#26 0x402bf543 in g_source_remove_by_funcs_user_data ()
   from /usr/lib/libglib-1.2.so.0
#27 0x402bfe7c in g_main_run () from /usr/lib/libglib-1.2.so.0
#28 0x40207139 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#29 0x0804a30b in main (argc=1, argv=0xbffffb14) at gaim.cpp:235
#30 0x4048e283 in __libc_start_main () from /lib/libc.so.6

This is the state of the thread that 'hangs'.

I will try a clobber build, but that's generally a too time/cpu intensive task.
(Reporter)

Comment 5

15 years ago
Don't know what the problem was. Closing.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Component: Embedding: GTK Widget → Embedding: GTK Widget
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.