Closed Bug 1440313 Opened 2 years ago Closed 2 years ago

Crash in void mozilla::ContainerState::FinishPaintedLayerData<T>

Categories

(Core :: Web Painting, defect, critical)

Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- fixed

People

(Reporter: gcp, Assigned: mattwoodrow)

References

Details

(Keywords: crash, regression)

Crash Data

Seems to be a new crasher in Nightly. I hit this on YouTube (though with a ton of other tabs open).

This bug was filed from the Socorro interface and is
report bp-068aa424-615c-4ee9-a9b1-2158f0180222.
=============================================================

Top 10 frames of crashing thread:

0 libxul.so void mozilla::ContainerState::FinishPaintedLayerData<mozilla::PaintedLayerDataNode::PopPaintedLayerData [clone .cold.839] 
1 libxul.so mozilla::PaintedLayerDataNode::PopPaintedLayerData 
2 libxul.so mozilla::PaintedLayerDataNode::Finish layout/painting/FrameLayerBuilder.cpp:2877
3 libxul.so mozilla::PaintedLayerDataNode::FinishAllChildren 
4 libxul.so mozilla::PaintedLayerDataNode::Finish layout/painting/FrameLayerBuilder.cpp:2829
5 libxul.so mozilla::ContainerState::Finish 
6 libxul.so mozilla::FrameLayerBuilder::BuildContainerLayerFor 
7 libxul.so nsDisplayOpacity::BuildLayer 
8 libxul.so mozilla::ContainerState::ProcessDisplayItems 
9 libxul.so mozilla::FrameLayerBuilder::BuildContainerLayerFor 

=============================================================
I hit it on Slack (see duplicate).
Component: Layout → Layout: Web Painting
Here's a URL to reproduce:

https://twitter.com/ZoeSCarpenter/status/966337408517181440

(Hint: will crash your tab on Linux.)
Duplicate of this bug: 1440318
Fixed by backing out bug 1436904.
Assignee: nobody → matt.woodrow
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.