Closed Bug 1440507 Opened 2 years ago Closed 2 years ago

Consider removing link.py xul wrapper

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox60 fixed)

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: chmanchester, Assigned: chmanchester)

References

Details

Attachments

(1 file)

I accidentally discovered while working on bug 1429875 that builds don't fail on try when link.py isn't used to wrap the linker. Tracking the link.py output script to https://bugzilla.mozilla.org/show_bug.cgi?id=915735#c41 (thanks to glandium), it seems notable linking xul in a pgo doesn't take anywhere near 2 hours anymore (the "still linking" message only ever shows up once), and the presumed reason the linker was getting killed at that point was buildbot.
Additionally, we've been using --output-sync=line for a while without issue in automation, which I think defeats printing the status message as well.
Assignee: nobody → cmanchester
Blocks: 1429875
Duplicate of this bug: 1407397
Comment on attachment 8953613 [details]
Bug 1440507 - Remove link.py wrapper script for linking xul.

https://reviewboard.mozilla.org/r/222824/#review228806

Nice!
Attachment #8953613 - Flags: review+
Attachment #8953613 - Flags: review?(core-build-config-reviews)
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/19bdbac4010c
Remove link.py wrapper script for linking xul. r=nalexander
https://hg.mozilla.org/mozilla-central/rev/19bdbac4010c
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.