If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Title of object shows wrong

VERIFIED DUPLICATE of bug 67127

Status

()

Core
XUL
VERIFIED DUPLICATE of bug 67127
16 years ago
16 years ago

People

(Reporter: Artem Skoretskiy, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When there's an "Enter" ASCII character in the title option of an "<a>" tag:

       <a href='#' title='First line
Second line
Third line'>Link</a>

       Text in the hint doesn't go to the next line, it just prints special
symbol and prints text in one line.


When content of the title option of an "<a>" tag is long:


       <a href='#' title='It is very long text.It is very long text.It is very
long text.It is very long text.It is very long text.It is very long text.It is
very long text.It is very long text.It is very long text.It is very long text.It
is very long text.It is very long text.It is very long text.It is very long
text.It is very long text.It is very long text.'>Link</a>

       Text doesn't go to the next line, the hint is just cut with "..." at the end.

When content of the title option of an "<a>" tag contains tags (like "<font
color='red'>", "<br>", etc.):

       <a href='#' title="<b>People:</b> First, Second, Third, <font
color='red'>Fouth</font><br><b>Rooms</b>">Link</a>

       Text is shown as is, i.e. as preformated text, but it should be
html-formated, i.e. color of the text should change color and decoration +
spaces and new lines should be made.
(Reporter)

Updated

16 years ago
Severity: normal → critical
Priority: -- → P3

Comment 1

16 years ago
dup of bug 67127 or bug 45375 (by way of bug 57599) ?
Sev -> Normal as Critical is for crashers.
Priority should only be set by Mozilla developers. Sorry if you're one of them,
please set it back to P3 then.
Thanks for the detailed bug report.
Assignee: Matti → jaggernaut
Severity: critical → normal
Component: Browser-General → XP Toolkit/Widgets
Priority: P3 → --
QA Contact: imajes-qa → jrgm

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.