Closed Bug 1440862 Opened 6 years ago Closed 6 years ago

Wording of Treeherder view for brand-new Try push has become less friendly

Categories

(Tree Management :: Treeherder: Frontend, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: botond, Assigned: camd)

References

Details

Attachments

(1 file)

There is a brief period of time after pushing to Try when Treeherder does not yet know about the pushed revision.

If you open Treeherder to that revision during this period, it displays a message saying it doesn't know about that revision yet.

The wording of this message has recently changed. It's now:

  "This is an invalid or unknown revision. Please change it, or click here to reload the latest revisions from try."

Whereas it used to be something like (recalling from memory here):

  "This revision is not known yet. Please wait until it's loaded from the pushlog database."

In both cases, the page auto-refreshes when the revision appears and all is well. However, I think the older message was more friendly, as it makes clear you didn't do anything wrong and just need to wait.
Thanks for filing!  I'll get this fixed asap.  It's a regression due to the React code migration.
Assignee: nobody → cdawson
Blocks: 1434677
Attachment #8954128 - Flags: review?(emorley)
Comment on attachment 8954128 [details] [review]
Link to GitHub pull-request: https://github.com/mozilla/treeherder/pull/3268

Looks good :-)
Attachment #8954128 - Flags: review?(emorley) → review+
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This seems to have regressed again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Botond Ballo [:botond] from comment #5)
> This seems to have regressed again.

Though, it seems, only intermittently.
Could you file a new bug please? (With as much STR as is viable given STR so tricky)
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
s/so/is/
Blocks: 1451492
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: