referers include fragments

VERIFIED DUPLICATE of bug 179400

Status

()

Core
Networking: HTTP
VERIFIED DUPLICATE of bug 179400
16 years ago
15 years ago

People

(Reporter: Jesse Ruderman, Assigned: Darin Fisher)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Netscape 4 and Mozilla send the hash part of a URL (the fragment identifier) in
the referer.  IE and Opera do not.

Mozilla is in violation of rfc 2616 [1].  Section 14.36 on referers states "The
URI MUST NOT include a fragment".  Fragments are the things after a # and aren't
actually part of the URI [2].

[1] http://community.roxen.com/developers/idocs/rfc/rfc2616.html (HTTP/1.1)
[2] http://community.roxen.com/developers/idocs/rfc/rfc2396.html (URIs)

Happens with Beonex 0.8 and Mozilla 0.9.9 (from my referer logs) and with 
2002 050908 on Windows 98.

Comment 1

16 years ago
confirming using build 2002051208 on Win2k (trunk).
Assignee: new-network-bugs → darin
Blocks: 61660
Component: Networking → Networking: HTTP
QA Contact: benc → tever
OS: Windows 98 → All
Hardware: PC → All
(Assignee)

Comment 2

16 years ago
mass futuring of untargeted bugs
Target Milestone: --- → Future

Comment 3

15 years ago
it was solved yesterday in bug 179400

*** This bug has been marked as a duplicate of 179400 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.