Account Manager: Click Accts & All Highlighted

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: Alec Flett)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build 1999092009M11: Win32/NT4, Linux/Redhat 6.0
(Mac: Can't try with this build due to difficulties with creating a new account)

Overview: After creating a new account through the Account Wizard, the Account
Settings dialog appears. Select an account, select another account and notice
that both accounts are highlighted.

Steps to reproduce:
1. Use a profile that already has one account defined.
2. Launch the Account Wizard, Edit/Account Setup.
3. Create a new account by selecting the "New Account" button.
4. Progress through all the Account Wizard dialogs.
5. On the last Account Wizard dialog select the "Finish" button and Account
Settings should display.
6. In the left pane select an account.
7. Double click onto the account so the Server and Copies panels appear.
8. Select the Server panel
9. Seleect the Copies panel
10.Select another account.

Actual Results: For steps #6-10 notice that everything selected is highlighted.
This happens only once, directly after creating a new account.
Workaround: Close Account Settings and reopen. Now after selecting various
accounts and panels it will behave as expected, only highlighting what you have
currently selected.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → nbaca
(Reporter)

Comment 1

18 years ago
QA Contact to nbaca.
(Reporter)

Comment 2

18 years ago
Additional Information:

On NT4 and Linux:
The Console states "JavaScript Error: Servernode has no properties
URL:
file:////u/nbaca/sea920/package/chrome/messenger/content/default/AccountManager.
js
LineNo: 177

Results on NT4: Select OK button and the Account Settings dialog closes as
expected.
Results on Linux: Select OK button and the Account Settings dialog becomes
blank. The only way to close this is by selecting the "x" box in the top right
corner.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: Acct Wiz -->Account Settings: Click Accts & All Highlighted → Account Manager: Click Accts & All Highlighted
(Assignee)

Comment 3

18 years ago
I think the "everything highlighted" is a tree bug, because I've seen it in the
folder pane too.
Scott or david, have you seen this behavior where everything you select gets
highlighted? It's kind of like what was happening in the threadpane...
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

18 years ago
So clearing the thread selection before I refresh the folder and server panes
seems to make a difference.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

18 years ago
Build 1999092409M11: Win32/NT4, Mac 8.5.1
Build 1999092309M11: Linux/Redhat 5.0
Verified Fixed.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.