Closed Bug 1441129 Opened 2 years ago Closed 2 years ago

Change the Memory Tool's Snapshot List Item delete button from a div to a button

Categories

(DevTools :: Memory, enhancement, P2)

enhancement

Tracking

(firefox60 fixed)

RESOLVED FIXED
Firefox 60
Tracking Status
firefox60 --- fixed

People

(Reporter: miker, Assigned: mayankmadan, Mentored)

Details

(Keywords: good-first-bug, Whiteboard: [lang=css,js])

Attachments

(3 files, 1 obsolete file)

For accessibility reasons we should change the Memory Tool's Snapshot List Item delete button from a div to a button.

The code to change is inside the following files:
- devtools/client/memory/components/SnapshotListItem.js
- devtools/client/themes/memory.css
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Can I work on this?
Hello sir, I am interested to work on it.I am new here.Can I do it?
Hi Mayank and Souvik !
Thanks a lot for your interest in this bug.

Because Mayank asked first I believe he should get the precedence to fix this bug :-)
Souvik I'm sure you'll find other bugs to work on!
Assignee: nobody → maddiemadan
Attached patch button.diff (obsolete) — Splinter Review
I think this patch will do
Flags: needinfo?(mratcliffe)
Flags: needinfo?(mratcliffe)
Attachment #8954866 - Flags: review?(mratcliffe)
Comment on attachment 8954866 [details] [diff] [review]
button.diff

Review of attachment 8954866 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for working on this so quickly!

I should have explained in the bug description that we want to preserve the appearance of the close button.

I would suggest that to accomplish this you drop your current CSS changes and add the following to `.snapshot-list-item .delete`:
  background-color: transparent;
  border: 0;
  color: currentColor;
  padding: 0;
Attachment #8954866 - Flags: review?(mratcliffe)
Attached patch button.diffSplinter Review
Attachment #8954866 - Attachment is obsolete: true
Attachment #8955075 - Flags: review?(mratcliffe)
Comment on attachment 8955075 [details] [diff] [review]
button.diff

Review of attachment 8955075 [details] [diff] [review]:
-----------------------------------------------------------------

Perfect, r+
Attachment #8955075 - Flags: review?(mratcliffe) → review+
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7516a83ba950
"Change the Memory Tool's Snapshot List Item delete button from a div to a button" [r=mratcliffe]
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/7516a83ba950
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.