Ensure language packs have unique version strings per AppVersion/Beta Version

RESOLVED FIXED in Firefox 60

Status

enhancement
RESOLVED FIXED
Last year
Last year

People

(Reporter: Callek, Assigned: Callek)

Tracking

Trunk
mozilla61
Dependency tree / graph

Firefox Tracking Flags

(firefox60 fixed, firefox61 fixed)

Details

Attachments

(1 attachment)

We need to make sure language packs have unique version strings from one release build to the next. This should roughly be equal to Appversion, but we'll need support for beta 1 being different from beta2 (incase we take new string changes) and we'll also need to keep in mind about ESR, which might be special here.

:Pike can you look into this?
Flags: needinfo?(l10n)
Product: Core → Firefox Build System
The version in the manifest is $(MOZ_APP_VERSION), that's good enough, right?

There's also a per-locale version inside the manifest, but I doubt we use that on AMO?
Flags: needinfo?(l10n)
(In reply to Axel Hecht [:Pike] from comment #1)
> The version in the manifest is $(MOZ_APP_VERSION), that's good enough, right?

It's not good enough. For example, [Firefox] 60 beta1 app version is "60.0", and it would also be "60.0" for beta 2.

And then again 60.0 for final (and esr too, -I think-).

What we need is a unique version for AMO that can be different between beta's, and ideally between seperate build's even in a single beta (e.g. final gets multiple rc's sometimes)

With things how they are we'd get one chance to upload a langpack between beta 1 and final, and no other changes until the first dot release.
Flags: needinfo?(l10n)
No idea what would satisfy those criteria.
Flags: needinfo?(l10n)
(In reply to Justin Wood (:Callek) from comment #4)
> Created attachment 8963773 [details]
> Bug 1441359 - Make langpack version include buildid.

After some trial and error and discussion among meetings we've come up with

<milestone.txt>buildid<buildid>  e.g. 61.0a1buildid2018... and 60.0buildid2018... and 60.0.1buildid2018...

And this patch does that, c.f. this try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=4a89d92eb37839852437f7fc651e573775d92842
Attachment #8963773 - Flags: review?(mshal) → review+
Comment on attachment 8963773 [details]
Bug 1441359 - Make langpack version include buildid.

https://reviewboard.mozilla.org/r/232642/#review238232
Pushed by mshal@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bf285f58e643
Make langpack version include buildid. r=mshal
https://hg.mozilla.org/mozilla-central/rev/bf285f58e643
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Assignee: nobody → bugspam.Callek
Comment on attachment 8963773 [details]
Bug 1441359 - Make langpack version include buildid.

Approval Request Comment
[Feature/Bug causing the regression]: Language Pack Signing
[User impact if declined]: Unable to automatically sign langpacks in 60. (Due to AMO conflicts with version number)
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: For the feature Bug 1441358
[Is the change risky?]: No
[Why is the change risky/not risky?]: This merely adds 'buildid' to the language pack version string, if it (buildid) is specified in the encapsulating environment, which is true for automation.
[String changes made/needed]: None
Attachment #8963773 - Flags: approval-mozilla-beta?
Comment on attachment 8963773 [details]
Bug 1441359 - Make langpack version include buildid.

Fix for langpack signing. Approved for 60.0b11.
Attachment #8963773 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.