Password manager should never remember an incorrect password

VERIFIED DUPLICATE of bug 127855

Status

MailNews Core
Networking
VERIFIED DUPLICATE of bug 127855
16 years ago
9 years ago

People

(Reporter: Dan Hensley, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Yesterday I tried to set up 1.0rc2 on my dad's W2K computer.  He has multiple
e-mail accounts with different passwords.  One account was set up fine.  When we
first tried to download e-mail from the second account, he entered the wrong
password, and had "Remember Password" checked.

From that point on, whenever he tried to check e-mail, it acted as though it was
checking, but e-mail was never downloaded, and he was never prompted to provide
the correct password for his 2nd account.

The problem is that the password manager remembered the incorrect password and
kept trying to use it.  This effectively blocked e-mail downloads for ALL his
accounts.  There was no feedback at all that this was the problem, and I only
was able to fix it after going into Preferences and removing the password from
the list.

Comment 1

16 years ago
To correct component.
Assignee: ssaux → morse
Component: Client Library → Password Manager
Product: PSM → Browser
QA Contact: junruh → tpreston
Version: 1.01 → other

Comment 2

16 years ago
But Password Manager is not the correct component -- mailnews is.

Password manager is only a servant doing what it is told.  It's up to the app to 
tell password manager to forget the password, and the app in this case is 
mailnews.
Assignee: morse → mscott
Component: Password Manager → Networking: MailNews General
Product: Browser → MailNews
QA Contact: tpreston → huang

Comment 3

16 years ago
Same is true for Navigator, however.
The problem is that you're prompted with the question "Should I remember the
password" *before* it is validated, so you have to decide *before* even knowing
if the password was ok. You cannot save the password later...

I think, as this is a general mis-feature, we should keep this bug app-agnostic...:)

Hugh

Comment 4

16 years ago
Resolving as duplicate. 

If you are seeing this problem on a non-IMAP mailbox, please say so in bug
127855. We'll change the summary to reflect the nature of the bug if that is the
case.

If this is not a duplicate, reopen.

*** This bug has been marked as a duplicate of 127855 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.