[Regression] [Quick Search] Doesn't work at all any more

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Erich.Iseli, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I've used this feature a lot with RC1 and since I have RC2, it doesn't work. I'm
trying to filter the e-mails with "general" in the subject or sender, here's
what happens:

1. Select the folder
2. Click into the search field
3. Type "general"
=> All messages still shown, even those not containing the string "general"

Expected result:
=> only messages with string "general" shown
(Reporter)

Updated

17 years ago
Blocks: 106943
Keywords: mozilla1.0, regression

Comment 1

17 years ago
Remember quicksearch will match sender, not just the display name, the actual
sender email.  So the string may be hidden from your view in the thread pane,
but should be identifiable in the sender header in the header envelope area.

Worksforme with our commercial branch build, may 07 and may09 builds on linux rh6.2.
(Reporter)

Comment 2

17 years ago
I know. The string was in the subject anyways. I tried it with the latest
nightly and it works. But what worries me is not the nightly, its RC2 which will
become Mozilla 1.0.

Comment 3

17 years ago
sometimes it works sometimes it doesn't. No javascript error or anything.. weird!
OS: Linux → All
Hardware: PC → All

Comment 4

17 years ago
It works when you first open mail/news, but very quickly it ceases to function.
 You have to close mozilla and reopen for it to work again.

Comment 5

17 years ago
Is this still happening for you with current builds?

Comment 6

17 years ago
It still happens with recent trunk nightlies.  (Current build: 2002061908).

Comment 7

17 years ago
Hey, are you by any chance switching views (View|Messages) while in (possibly
previous) quicksearch results?  In some cases that can cause weirdness in the
search bar without any error... a couple scenarios I noticed are described in
bug 148001, but there may be more.  
mass re-assign.
Assignee: naving → sspitzer
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail

Comment 9

14 years ago
--> WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050604
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.