Closed Bug 1441719 Opened 4 years ago Closed 4 years ago

clang-format fails: Could not find artifacts for a toolchain build named `win64-clang-tidy`

Categories

(Firefox Build System :: Source Code Analysis, defect)

x86_64
Windows 10
defect
Not set
normal

Tracking

(firefox60 fixed)

RESOLVED FIXED
Tracking Status
firefox60 --- fixed

People

(Reporter: bryce, Assigned: andi)

References

Details

When running `./mach clang-format` on my Windows 10 setup I receive the following error:

> Could not find artifacts for a toolchain build named `win64-clang-tidy`. Local commits and other changes in your checkout may cause this error. Try updating to a fresh checkout of mozilla-central to use artifact builds.

This issue persists when running on a central changeset and after a bootstrap. clang-format has worked previously on this machine, though it's been at least a month since my last attempt.
We moved from self built clang-format binary to tc based.
I guess this is the issue.
Andi, could you please have a look? Thanks
Assignee: nobody → bpostelnicu
Blocks: 1405554
(In reply to Bryce Van Dyk (:bryce) from comment #0)
> When running `./mach clang-format` on my Windows 10 setup I receive the
> following error:
> 
> > Could not find artifacts for a toolchain build named `win64-clang-tidy`. Local commits and other changes in your checkout may cause this error. Try updating to a fresh checkout of mozilla-central to use artifact builds.
> 
> This issue persists when running on a central changeset and after a
> bootstrap. clang-format has worked previously on this machine, though it's
> been at least a month since my last attempt.

Are there any modifications in these locations:

build/clang-plugin
build/build-clang
taskcluster/scripts/misc/build-clang-windows-helper64.sh
taskcluster/taskgraph/transforms/job/toolchain.py
taskcluster/scripts/misc/build-clang-tidy64-windows.sh
browser/config/tooltool-manifests/win32/build-clang-cl.manifest

If so they need to be reverted since there are no builds on TC that have hashes corresponding with those modifications. 

If those paths are clean then something happened with TC and the builds were not triggered, in this case i will talk with a sheriff to start them manually.
Flags: needinfo?(bvandyk)
I can confirm this on win64 it seems that the clang-tidy package is missing, I've started another build that can be tracked here:

https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=ee326c976eebdca48128054022c443d3993e12b0&filter-searchStr=toolchain
Now everything should work, doing this:

>>./mach artifact toolchain --from-build win64-clang-tidy

Also works. 
Please let me know if this is fixed for you.
All good again for me. Thanks!
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(bvandyk)
Resolution: --- → FIXED
Depends on: 1441880
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.