Browser goes to wrong server to get a page's files w/Sparc Solaris rc1 build

VERIFIED DUPLICATE of bug 38488

Status

()

Core
Networking
--
major
VERIFIED DUPLICATE of bug 38488
16 years ago
16 years ago

People

(Reporter: Chris Pinard, Unassigned)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0rc1) Gecko/20020418
BuildID:    2002041818

In more recent versions, this only happens occasionally, but every so often,
going from one site's pages to another's, the browser will try to load the page
from a previous site's server. Sometimes, if I hit Reload, or go to the URL bar
and hit enter again, it'll wake up and do the right thing, but not always.

Reproducible: Sometimes
Steps to Reproduce:
1. Load up Mozilla for Solaris 8/SPARC
2. Browse around for a while.


Actual Results:  Typically, a 404 Not Found from the previous site's server,
'cause it couldn't find the desired site's page.

Expected Results:  Fetched the page from the correct server.

I'll see about getting a screenshot attached that shows an example of the result
I got.
(Reporter)

Comment 1

16 years ago
Created attachment 83356 [details]
Screen shot of browser that's gone to Sun's server to get TolkLang server pages.

Was browsing around a bunch to duplicate this bug and document it. Went to
http://www.sun.com/executives/realitycheck/headsup010205.html , then tried to
load http://www.dcs.ed.ac.uk/misc/local/TolkLang/ . As you can see, it
attempted to load the TolkLang page from Sun's server, and, naturally, got a
404 for its trouble.
(Reporter)

Comment 2

16 years ago
Also, BTW, I haven't tried this with rc2, but there isn't an rc2 build available
for Sparc Solaris 8 yet.
Summary: Browser goes to wrong server to get a page's files → Browser goes to wrong server to get a page's files w/Sparc Solaris rc1 build
Reporter:
Are you using a proxy ?
(Reporter)

Comment 4

16 years ago
Not a full-scale proxy, but I run my own copy of the Junkbuster proxy to filter
out ad images. Junkbuster's logs show that when this bug kicks in, the jb isn't
asked to retreive anything.
junkbuster is broken

change Http/1.1 to Http/1.0 in the preferences and clear the disk cache

dupe of an invalid bug.


*** This bug has been marked as a duplicate of 38488 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.