Closed Bug 1441961 Opened 2 years ago Closed 2 years ago

devtools/client/netmonitor/test/browser_net_view-source-debugger.js is going to permafail when Gecko 60 merges to Beta on 2018-03-01

Categories

(DevTools :: Netmonitor, defect, blocker)

defect
Not set
blocker

Tracking

(firefox-esr52 unaffected, firefox58 unaffected, firefox59 unaffected, firefox60 verified)

VERIFIED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- verified

People

(Reporter: aryx, Unassigned)

Details

central-as-beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&revision=47f90d887c656d192abaf8cb49f2558eb7af72a2&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable&selectedJob=164893749

Log: https://treeherder.mozilla.org/logviewer.html#?job_id=164892975&repo=try
08:54:52     INFO - TEST-PASS | devtools/client/netmonitor/test/browser_net_view-source-debugger.js | Request to reconfigure the tab was recorded. - 
08:54:52     INFO - Clearing requests in the console client.
08:54:52     INFO - Clearing requests in the UI.
08:54:52     INFO - Starting test... 
08:54:52     INFO - > Network event progress: NetworkEvent: 1/2, PayloadReady: 0/2, got NetMonitor:NetworkEvent for server1.conn105.child1/netEvent28
08:54:52     INFO - > Network event progress: NetworkEvent: 1/2, PayloadReady: 1/2, got NetMonitor:PayloadReady for server1.conn105.child1/netEvent28
08:54:52     INFO - > Network event progress: NetworkEvent: 2/2, PayloadReady: 1/2, got NetMonitor:NetworkEvent for server1.conn105.child1/netEvent29
08:54:52     INFO - > Network event progress: NetworkEvent: 2/2, PayloadReady: 2/2, got NetMonitor:PayloadReady for server1.conn105.child1/netEvent29
08:54:52     INFO - Clicking stack-trace tab and waiting for stack-trace panel to open
08:54:52     INFO - Buffered messages finished
08:54:52     INFO - TEST-UNEXPECTED-FAIL | devtools/client/netmonitor/test/browser_net_view-source-debugger.js | Test timed out - 

There was a change from peterv to the file yesterday but there is no evidence yet that this is related: https://hg.mozilla.org/mozilla-central/filelog/tip/devtools/client/netmonitor/test/browser_net_view-source-debugger.js

Last good central-as-beta simulation was with https://hg.mozilla.org/mozilla-central/rev/bd6e200b5a6b
Flags: needinfo?(odvarko)
Flags: needinfo?(ntim.bugs)
Flags: needinfo?(jlaster)
Regression from bug 888600 because it modified the test?
Flags: needinfo?(peterv)
Flags: needinfo?(ntim.bugs) → needinfo?(poirot.alex)
Hi. The first try push (good) from Aryx has all the dt3 jobs successful (with 10 retriggers). The other one has the jobs failed.
central-as-beta simulation with bug 888600 backed out succeeded: https://treeherder.mozilla.org/#/jobs?repo=try&revision=d5df390036cea740eabc0938b6d2102908af2977&selectedJob=165071975
The new Linux opt bustages are from a different bug.

Bug 888600 got backed out from central.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(poirot.alex)
Flags: needinfo?(odvarko)
Flags: needinfo?(jlaster)
Resolution: --- → FIXED
Product: Firefox → DevTools
Flags: needinfo?(peterv)
You need to log in before you can comment on or make changes to this bug.