Accessing java applets with document.applets['applet name']

RESOLVED DUPLICATE of bug 138684

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 138684
16 years ago
16 years ago

People

(Reporter: Luiz Henrique Shigunov, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051009

Cannot login to https://www2.bancobrasil.com.br/aapf/aai/login.pbk. It seems
this function is not working (it's called in the onSubmit event):
function getSenha() {
	//alert("hidden1: " + document.form.elements['senhaConta'].value);
	if ( document.applets['tclJava'] ){
		var senha = document.applets['tclJava'].getSenha();
		//alert("senha: " + senha);
		document.form.elements['senhaConta'].value = senha;
	}
}

The site says that the password (senha) is null (doesn't exist) when I submit
the page.

This page works with Netscape 6.2.2 with the same JRE:
Java(TM) Plug-in: Version 1.4.0
Using JRE version 1.4.0 Java HotSpot(TM) Client VM

There's no error in the javascript console.

Reproducible: Always
Steps to Reproduce:
1.Go to https://www2.bancobrasil.com.br/aapf/aai/login.pbk
2.
3.

Comment 1

16 years ago
This is a duplicate of bug 138684,
"Account password entered in Java applet does not get through to the server"

Reassigning to DOM Level 0 for parity with other bug -
Assignee: rogerl → jst
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → DOM Level 0
Ever confirmed: true
QA Contact: pschwartau → desale

Comment 2

16 years ago
Marking as duplicate. Luiz, thank you for this report. See the discussion
in bug 138684. You will be cc'ed on that bug so you can follow its progress -

*** This bug has been marked as a duplicate of 138684 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.