Closed Bug 1442271 Opened 2 years ago Closed 3 months ago

Cookie imports fail on newer versions of Chrome and/or Linux

Categories

(Firefox :: Migration, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 69
Tracking Status
firefox60 --- fix-optional
firefox69 --- fixed

People

(Reporter: Gijs, Assigned: trishul.goel)

References

Details

Attachments

(1 file)

Apparently the 'secure' and 'httponly' (and perhaps other, I stopped trying at this point) columns are no longer present in the cookies db. We actually use some of these columns, so we'll need to check where this data went. It's also possible that this only happens for chrome profiles created on recent versions of Chrome, or something, because I can't reproduce on my mac with current release of Chrome.
Marking as P3 as we already didn't import the encrypted cookies and not importing cookies isn't generally seen as dataloss. Imported cookies can also cause problems anyways.
Keywords: regression
Priority: -- → P3
See Also: → 1163165, 1163166, 1163167
Marking fix-optional for P3 given comment 1. RyanVM also suggested removing the regression keyword.
Assignee: nobody → trishul.goel

Cookie imports fail on newer versions of Chrome

Status: NEW → ASSIGNED
Keywords: checkin-needed

Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/350f7249407d
Cookie imports fail on newer versions of Chrome r=Gijs

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
You need to log in before you can comment on or make changes to this bug.