Closed Bug 1442294 Opened 2 years ago Closed 2 years ago

When video disabled (A/V situation) the red camera icon (URL bar) should be downgraded to the red microphone icon(URL bar)

Categories

(Core :: WebRTC: Audio/Video, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla60
Tracking Status
firefox60 --- verified

People

(Reporter: adrian_sv, Assigned: johannh)

Details

Attachments

(1 file)

[Description:]
Based on:
https://bugzilla.mozilla.org/show_bug.cgi?id=1436033#c9
https://bugzilla.mozilla.org/show_bug.cgi?id=1436033#c14
https://drive.google.com/file/d/0B8kj4Mlm-HJecktURGQzanI0c1U/view
https://bugzilla.mozilla.org/show_bug.cgi?id=1333468

This only concerns the scenario in which the video gets disabled (not unplugged - which is handled in other bugs). 

[Steps:]
1. Start an A/V call (A/V have different sources - headset/webcam).
2. Disable(mute) the video feed - sound remains on.
3. Click on the blinking red camera in the URL bar.

[Actual Result:]

video feed - disabled
sound feed - enabled

video indicator (URL bar) - active (red blinking camera)
sound indicator (URL bar) - not displayed 

video indicator (permissions block) - disabled (grey icon)
sound indicator (permissions block) - active (red blinking microphone)



[Expected Result:]

video feed - disabled
sound feed - enabled

video indicator (URL bar) - not displayed 
sound indicator (URL bar) - active (red blinking microphone)

video indicator (permissions block) - disabled (grey icon)
sound indicator (permissions block) - active (red blinking microphone)
Assignee: nobody → jhofmann
Rank: 15
Priority: -- → P2
Status: NEW → ASSIGNED
Comment on attachment 8957131 [details]
Bug 1442294 - Downgrade global streaming indicator when a higher priority device has been disabled.

https://reviewboard.mozilla.org/r/226070/#review232042

The code change looks good. I'll r+ if you can convince me that we already have a test covering this case:
share audio+video, disable video, check sharing indicator, re-enable video, check sharing indicator
or if you add it :-)
(In reply to Florian Quèze [:florian] from comment #3)
> Comment on attachment 8957131 [details]
> Bug 1442294 - Downgrade global streaming indicator when a higher priority
> device has been disabled.
> 
> https://reviewboard.mozilla.org/r/226070/#review232042
> 
> The code change looks good. I'll r+ if you can convince me that we already
> have a test covering this case:
> share audio+video, disable video, check sharing indicator, re-enable video,
> check sharing indicator
> or if you add it :-)

This test takes care of that, with the changes to head.js

https://searchfox.org/mozilla-central/rev/588d8120aa11738657da93e09a03378bcd1ba8ec/browser/base/content/test/webrtc/browser_devices_get_user_media_paused.js#18

Thanks!
Comment on attachment 8957131 [details]
Bug 1442294 - Downgrade global streaming indicator when a higher priority device has been disabled.

https://reviewboard.mozilla.org/r/226070/#review232166
Attachment #8957131 - Flags: review?(florian) → review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2a403dec22d8
Downgrade global streaming indicator when a higher priority device has been disabled. r=florian
https://hg.mozilla.org/mozilla-central/rev/2a403dec22d8
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Flags: qe-verify+
I verified this issue on Mac OS X 10.12, Ubuntu 16.04, Windows 10 with FF Nightly 60.0a1(2018-03-12) and I can't reproduce this issue anymore. I also verified this issue on Nightly 60.0a1(2018-03-01) and I was able to reproduce it. Based on the the results mentioned above, I will mark this as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.