Closed Bug 14425 Opened 20 years ago Closed 20 years ago

get little spinny thing when I go to ftp://ftp.mozilla.org, then click on the + next to /etc

Categories

(SeaMonkey :: General, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: sspitzer, Assigned: waterson)

Details

here's the stack:

#0  0x408ac0c9 in Assertion::Assertion (this=0x8c1b8e0, aSource=0x0,
aProperty=0x895e9b0, aTarget=0x81b86c0, aTruthValue=1) at
nsInMemoryDataSource.cpp:116
#1  0x408adebb in InMemoryDataSource::LockedAssert (this=0x8ba8588, source=0x0,
property=0x895e9b0, target=0x81b86c0, tv=1) at nsInMemoryDataSource.cpp:935
#2  0x408adf92 in InMemoryDataSource::Assert (this=0x8ba8588, source=0x0,
property=0x895e9b0, target=0x81b86c0, tv=1) at nsInMemoryDataSource.cpp:976
#3  0x41694f4a in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/components/libdirectory.so
#4  0x4095ed33 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/components/libnecko.so
#5  0x4095e763 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/components/libnecko.so
#6  0x4018a2bb in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/libplds3.so
#7  0x4018a1cc in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/libplds3.so
#8  0x4014e9ed in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/libxpcom.so
#9  0x40540686 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/libwidget_gtk.so
#10 0x40721789 in ?? () from /usr/lib/libgdk-1.2.so.0
#11 0x4074dd6a in ?? () from /usr/lib/libglib-1.2.so.0
#12 0x4074f2c6 in ?? () from /usr/lib/libglib-1.2.so.0
#13 0x4074f801 in ?? () from /usr/lib/libglib-1.2.so.0
#14 0x4074f979 in ?? () from /usr/lib/libglib-1.2.so.0
#15 0x4067ef3a in ?? () from /usr/lib/libgtk-1.2.so.0
#16 0x40540e59 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/libwidget_gtk.so
#17 0x403b7e91 in ?? () from
/home/sspitzer/MOZILLA/06.20.1999/09.22/mozilla/dist/bin/libnsappshell.so
#18 0x804b4d7 in main1 (argc=1, argv=0xbffff984) at nsAppRunner.cpp:591
#19 0x804b759 in main (argc=1, argv=0xbffff984) at nsAppRunner.cpp:702
#20 0x40288cb3 in ?? () from /lib/libc.so.6
Seth: are you still seeing this? I am not able to reproduce...
Summary: CRASH: ftp://ftp.mozilla.org, then click on the + next to /etc → get little spinny thing when I go to ftp://ftp.mozilla.org, then click on the + next to /etc
it no longer crashes.

now I get a little animate gif (looks like two arc'd arrows chasing each others
tails)

do you see that?

but no crash.

I can still click around and open other things, (like /pub).

I changed the summary to reflect this.

if this is the right behaviour, make this invalid.
Status: NEW → ASSIGNED
Target Milestone: M12
Well, the spinny thing is supposed to eventually _stop_ spinning. But I see
that it doesn't. :-/

I tell it to stop when I get a OnStopRequest() -- Jud, will that happen if the
directory is empty?
I'm sending a stop, but not a start. Can you start the spinner only on a
OnStart(), rather than on click (which is what I assume you're doing)? Or would
that introduce too much lag experience lag?
Yeah, that was what I tried originally; but there is _huge_ latency between
"click" and "start" (and almost no latency between "start" and "stop"). I'm
just so if you do always send a stop, i should be picking it up. Lemme go look
some more.
is this still a problem? i'd like to mark as INVALID or WORKSFORME, because
ftp: seems to be doing allright these days...
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
onstops() are always fired. this is an old problem regarding a listener being
able to handle *only* an onstop() without having gotten an onstart(). I now fire
an onstart nomatter what so this is gone.
Status: RESOLVED → VERIFIED
yes, this is fixed.  marking verified.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.