Closed Bug 1442519 Opened 4 years ago Closed 4 years ago

Failure to sync storage-sync-crypto due to server imposed quota

Categories

(WebExtensions :: Storage, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1484968

People

(Reporter: markh, Unassigned)

Details

From bug 1234400 comment 8, Graham reports his Sync error logs show:

1519302016769    Sync.Engine.Extension-Storage    ERROR    Syncing
storage-sync-crypto: request failed: Error: HTTP 507; Error: HTTP 507
Insufficient Storage: Resource access is forbidden for this user (Maximum bytes
per object exceeded (19185 > 16384 Bytes.)
(resource://services-common/kinto-http-client.js:2353:21) JS Stack trace:
formatResponse@kinto-http-client.js:2376:21 <
processResponse@kinto-http-client.js:2351:14

What makes this "interesting" is the reference to storage-sync-crypto - which IIUC is probably a lot worse than a single extension failing due to the quota.

Graham offered to share more info from his logs if it was helpful, but I don't what information might be helpful here.
Thanks for the spin-off. 

If it helps … in my case, the first thing that comes to mind is: 

- the number of add-ons. 

91 language packs – all of which are system add-ons, bundled with Waterfox (56.0.4_4 on FreeBSD-CURRENT). I imagine that _system_ add-on metadata is not synced. 

306 extensions at the time of writing, none of which is a system extension. 

(I do have 'Firefox Screenshots' 10.12.0 but it's hand-installed, not at a system path, and whilst its metadata might be synced I don't expect the extension to be synced – because it's not on AMO.) 

    Might this high number – 306 – be 
    a major contributor to the excess?

(Why so many? Because when I test and reject an extension, I usually disable it. More user-friendly than removing, then attempting to rediscover on AMO. 216 disabled at the time of writing.)

----

The second thing that comes to mind: 

- the number of tabs. 

1,316 in my current session. (More than 1,500 in the past … I'm gradually reducing the number.)

----

Happy to share info from about:support and so on.
Oh, and … 

(In reply to Mark Hammond [:markh] from comment #0)

> … What makes this "interesting" is the reference to storage-sync-crypto …

Understood. 

In that context, yes, my comment 1 is waffle :-) but may help to visualise the use case.
Product: Toolkit → WebExtensions
Duping this based on the comments, but acknowledging there may be a bug (if markh deems it so) on the sync side.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1484968
You need to log in before you can comment on or make changes to this bug.