Closed Bug 1442580 Opened 7 years ago Closed 6 years ago

alt+shift+s should open the dialog for Clear History from about:preferences#privacy page

Categories

(Firefox :: Settings UI, defect)

60 Branch
defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox60 --- affected

People

(Reporter: btot, Unassigned)

Details

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60
Build ID 20180301223350

[Affected versions]:
Nightly 60.0a1

[Affected platforms]:
Windows 10 x64, Windows 7 x32, Ubuntu 16.04 x64

[Steps to reproduce]:
1. Launch Nightly 60.0a1 with a new profile
2. Go to about:preferences#privacy
3. Hit alt+shift+s(accesskey for Clear History button)

[Expected results]:
Clear Recent History dialog should be opened.

[Actual result]:
"Clear history" button is selected, but Clear Recent History dialog is not opened.


Note:
Only Clear History button is associated with alt+shift+s access key on the about:preferences#privacy page.
If hit alt+shift+i(the accesskey for Settings button from "Cookies and Site Data" ), the Settings - Cookies and Site Data dialog is opened.
Whiteboard: [storage-v2][triage]
We don't really know why this is happening but we don't consider it important enough to track in the storage-v2 project (you can still press enter to get the dialog).

Maybe jaws has an idea, otherwise it's probably safe to P5 this.
No longer blocks: storage-v2
Whiteboard: [storage-v2][triage]
This is happening because the "Select one automatically" (selectCerts.auto) has an accesskey of "S" (selectCerts.auto.accesskey). Changing that accesskey from "S" to "x" fixed the bug for me.

The radio button for "Select one automatically" is in the Certificates section which is also displayed in Privacy & Security. It's a bug that we aren't scrolling with the focus changes.

The simplest fix here would be to use a different accesskey for one of these due to the conflict.

Brindusa, is this a regression?
Flags: needinfo?(brindusa.tot)
Ah, I didn't consider that one. I think if there's another element with that accesskey this is working as intended, this bug was created because we thought there isn't another element with "S". It's probably safe to close as WORKSFORME.

I'll leave the ni for Brindusa to confirm this :)

Jared, do you know where we're tracking the lack of scrolling with focus changes in about:preferences?

Thanks!
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(jaws)
Resolution: --- → WORKSFORME
Maybe invalid is a better resolution, thinking about it.
Resolution: WORKSFORME → INVALID
alt+shift+s is not getting me to the "Select one automatically" from Certificates section on the Nightly 60.0a1, Build ID 20180311220116. The cursor remains stick on the Clear History button no matter how many times I press alt+shift+s.
Johann, is this working for you?

On the 59.0 RC, Build ID 20180310025718, the alt+shift+s gets me to the "Select one automatically" radio button from Certificates section.
Flags: needinfo?(brindusa.tot) → needinfo?(jhofmann)
I couldn't find a bug on file for the issue found in this bug, so I filed a new one at bug 1445376.
Flags: needinfo?(jaws)
(In reply to Brindusa Tot[:brindusat] from comment #5)
> alt+shift+s is not getting me to the "Select one automatically" from
> Certificates section on the Nightly 60.0a1, Build ID 20180311220116. The
> cursor remains stick on the Clear History button no matter how many times I
> press alt+shift+s.
> Johann, is this working for you?
> 
> On the 59.0 RC, Build ID 20180310025718, the alt+shift+s gets me to the
> "Select one automatically" radio button from Certificates section.

I think jaws described the issue in bug 1445376 correctly, so we can keep this closed :)
Flags: needinfo?(jhofmann)
You need to log in before you can comment on or make changes to this bug.