Closed Bug 1442602 Opened 2 years ago Closed 2 years ago

Frame component does not handle browser-loader issued urls

Categories

(DevTools :: Shared Components, defect, P2)

defect

Tracking

(firefox60 fixed)

RESOLVED FIXED
Firefox 60
Tracking Status
firefox60 --- fixed

People

(Reporter: miker, Assigned: nchevobbe)

References

Details

Attachments

(1 file, 1 obsolete file)

STR:

1. Open the browser console.
2. Type window [enter].
3. Click the link next to the svg error.

A view-source window opens but the URL it tries to use is "view-source:resource://devtools/shared/base-loader.js -> resource://devtools/client/framework/toolbox.js", which will never work.

The original test checks for exactly this issue so it is blocked until this is fixed.
Attachment #8955479 - Attachment is obsolete: true
Has Regression Range: --- → irrelevant
Has STR: --- → yes
Placing this in the Frame component since it seems more relevant to me to fix this there to cover all the panels using it.
Component: Developer Tools: Console → Developer Tools: Shared Components
Summary: Browser console view source url wrong when exception is thrown → Frame component does not handle browser-loader issued urls
Assignee: nobody → nchevobbe
Comment on attachment 8955554 [details]
Bug 1442602 - Fix Frame component for browser-loader requested resources; .

https://reviewboard.mozilla.org/r/224696/#review230762
Attachment #8955554 - Flags: review?(mratcliffe) → review+
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/88d7a7d93abf
Fix Frame component for browser-loader requested resources; r=miker.
https://hg.mozilla.org/mozilla-central/rev/88d7a7d93abf
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.