Closed Bug 1442632 Opened 4 years ago Closed 5 months ago

ImageBitmapOptions does not override pixelstorei

Categories

(Core :: Canvas: WebGL, defect, P3)

60 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1367251
Tracking Status
firefox58 --- affected
firefox59 --- affected
firefox60 --- affected

People

(Reporter: ivan.popelyshev, Unassigned)

References

Details

(Whiteboard: gfx-noted)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36

Steps to reproduce:

Open https://fiddle.jshell.net/sosw339h/36/

Alpha component of the image is 0.5

createImageBitmap params dont affect the result, pixelstorei params do.

According to https://www.khronos.org/registry/webgl/specs/1.0/#PIXEL_STORAGE_PARAMETERS , it has to be the other way around.


Actual results:

Premultiplied and non-premuiltiplied bunnies look the same.


Expected results:

Premultiplied (PM) bunny should be over-lighted, because his ImageBitmap wasnt premultiplied according to ImageBitmapOptions.
Hi Ivan,

I tested this issue on Windows 10 x64 and Mac OS X 10.12 with FF 58 release and FF NIghtly 60.0a1(2018-03-07) and I can reproduce it.
Status: UNCONFIRMED → NEW
Component: Untriaged → Canvas: WebGL
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Version: 58 Branch → 60 Branch
Jeff it looks like its your area, feel free to reassign.
Assignee: nobody → jgilbert
Whiteboard: gfx-noted
(In reply to ovidiu boca[:Ovidiu] from comment #1)
> Hi Ivan,
> 
> I tested this issue on Windows 10 x64 and Mac OS X 10.12 with FF 58 release
> and FF NIghtly 60.0a1(2018-03-07) and I can reproduce it.

Thank You! My example is a bit strange because I wanted to prove that chrome that bug first, then I read the specification and found out that bunnies has to be different in that case. 

Somehow, all other browsers dont follow specs. There's also the problem that "createImageBitmap(bitmap, options)" signature throws error in firefox.

Original demo was on pixijs, and it took time to strip it down to pure webgl calls.
Guys? Is anyone here?
I can't work on this for the moment.
There's known work on our ImageBitmap implementation that we know needs to be done, but we're fighting fires elsewhere right now.
Thanks for the testcase! That'll make it easier on us.
Assignee: jgilbert → nobody
Priority: -- → P3
fiddle.jshell.net removed that example, I have to find it in my files again. Did you save it or is there any archive that I sent? I dont see it in this page :(
Oh no! I hadn't checked it recently, unfortunately. Your description is good, so we should be able to recreate it though!
Depends on: 1367251

This has been fixed by 1367251

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1367251
You need to log in before you can comment on or make changes to this bug.