Starting Firefox with -private-window <url> launches a second non private window

VERIFIED FIXED in Firefox 60

Status

()

defect
VERIFIED FIXED
a year ago
10 months ago

People

(Reporter: lola_j22, Assigned: mkaply)

Tracking

({regression})

60 Branch
Firefox 60
Points:
---
Bug Flags:
in-qa-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 unaffected, firefox59 unaffected, firefox60 verified, firefox61 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20100101

Steps to reproduce:

* Install latest Firefox 60, run it (or don't)
* Attempt to open Firefox with firefox.exe -private-window example.com


Actual results:

A new private window opens with example.com.
A second non private window opens on top of the requested page.


Expected results:

The second window should not appear.

Comment 1

a year ago
regressionwindow
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
20180309100425

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2667f0b010c959940d7a12b4311d54a6abd74ac5&tochange=b2a9a4bb5c94de179ae7a3f52fde58c0e2897498

Suspect: bug 1432355.

I wasn't able to narrow the range any further because I'm currently getting a CloudFront error when trying the inbound and autoland directory listings.
Blocks: 1432355
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Private Browsing
Ever confirmed: true
Flags: needinfo?(mozilla)
Keywords: regression
OS: Unspecified → All
Hardware: Unspecified → All

Updated

a year ago
Duplicate of this bug: 1444450
Comment hidden (mozreview-request)
(Assignee)

Comment 4

a year ago
Accidentally removed a needed line on the policy checkin.
Assignee: nobody → mozilla
Flags: needinfo?(mozilla)

Comment 5

a year ago
mozreview-review
Comment on attachment 8957694 [details]
Bug 1442749 - Add back line accidentally removed in bug 1432355.

https://reviewboard.mozilla.org/r/226614/#review232476

How did this slip in? The cset I reviewed didn't remove this, and this was autolanded. So how did we end up with a revision that removed this on mozreview? :-\

Unfortunately the interdiff reviewboard provides on the old patch is no use for determining this at all because it crosses a rebase so 99% of it is unrelated junk.
Attachment #8957694 - Flags: review?(gijskruitbosch+bugs) → review+

Comment 6

a year ago
Also, could you file a follow-up to add marionette / firefox-ui-functional tests for the commandline handlers?

Comment 7

a year ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/010b589f89a0
Add back line accidentally removed in bug 1432355. r=Gijs

Comment 8

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/010b589f89a0
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
It is verified as fixed. Only one private window appears this time.

Screen capture- https://testing-1.tinytake.com/sf/MjQzMDM5Ml83MzU0Mjg1

If "DisablePrivateBrowsing" policy is active, a normal window appears and it navigates to about:privatebrowsing (which is blocked by the policy).
Status: RESOLVED → VERIFIED
Nightly 61.0a1 and Build ID-20180312134431 is used for testing.

Updated

a year ago
Duplicate of this bug: 1445568

Comment 12

a year ago
(In reply to :Gijs from comment #6)
> Also, could you file a follow-up to add marionette / firefox-ui-functional
> tests for the commandline handlers?

Mike, did this happen?
Flags: needinfo?(mozilla)
(Assignee)

Comment 13

a year ago
> Mike, did this happen?

Not yet. Was on my list for today. I'll do it now.
Flags: needinfo?(mozilla)
We also verified this on beta and it is fixed.
Test cases and runs are here- https://testrail.stage.mozaws.net/index.php?/plans/view/8760
Flags: in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.