Closed Bug 1442762 Opened 3 years ago Closed 5 months ago

"Open Pop-up Windows" site permissions' drop-down list items are too narrow

Categories

(Firefox :: Site Permissions, defect, P3)

53 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 76
Tracking Status
firefox-esr68 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- verified

People

(Reporter: cpeterson, Assigned: aarushivij)

References

Details

(Keywords: regression)

Attachments

(4 files)

STR:
1. Open http://www.popuptest.com/popuptest1.html
2. Click the site permissions (i) button in the address bar.
3. Click to expand the "Open Pop-up Windows" section's Allow/Block drop-down list.

RESULT:
On Windows, the drop-down list items "Allow" and "Block" are narrower than the drop-down list's header with the arrow. See the attached screenshot.

On macOS, the drop-down list is the correct width, but the list is too far to the left and not aligned with the drop-down list's header.
Since Prathiksha doesn't have a Windows machine, we might need to find someone else to look into this.
Component: Site Identity → Site Permissions

Hello, can I work on this?
I can reproduce the issue on linux too. (Dropdown has different width compared to header)
Do I need to make drop down's list item width equal to lists header?
Thanks
Aarushi :)

Flags: needinfo?(Virtual)

I'm not proper person to fully answer this question, so I'm redirecting it Johann Hofmann [:johannh].

Flags: needinfo?(Virtual) → needinfo?(jhofmann)
Attached image after.png

Hello Johann ,
I was trying to fix the bug.
Is it how it should look?
Shall push the patch once confirmed by you :)
Thanks

Yeah, that's about how I would expect things to look, though I guess it depends on the approach :)

Thanks!

Assignee: nobody → aarushivij
Status: NEW → ASSIGNED
Flags: needinfo?(jhofmann)

Okay, Thanks Johann
Shall push the patch :)

Hello, this bug does seem to be a regression, as the first builds in which the drop-down was implemented it looked okay, soon after though the drop-down elements changed to the more narrow version. I've tried to find a specific build using mozregression but it seems it can't reach all the builds, however, this is what I've found:

last known good build: 2017-10-26 pushlog
first known bad build: 2017-10-27 pushlog

Has Regression Range: --- → yes

(In reply to Daniel Kolsis from comment #9)

[...] first known bad build: 2017-10-27 pushlog

For this regression changelog, bug #1411290 looks most suspicious.

Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b3c3f7d0f044
Open Pop-up Windows site permissions drop-down list items are too narrow r=dao
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
Flags: qe-verify+

Reproduced the issue using Firefox 60.0a1 (20180302220122) on Windows 10x64.
The issue is verified fixed with Firefox 76.0b4 (20200412214314) on Windows 10x64 and ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.