Failed spidermonkey jobs do not upload binaries

RESOLVED FIXED in Firefox 60

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: sfink, Assigned: sfink)

Tracking

unspecified
mozilla60
Points:
---

Firefox Tracking Flags

(firefox60 fixed)

Details

Attachments

(1 attachment)

I was looking through some ancient patches, and found this one that I thought I had already landed. nbp ran into this some time ago, where he was trying to reproduce a try failure but it unhelpfully would not give him the binary that it was using to fail the test. (If I remember correctly, the issue ended up being that try turns off ASLR?)
Attachment #8955686 - Flags: review?(nicolas.b.pierron)
Argh. Lost my attachment comment.

The problem is that a calling script without set -e was sourcing a script with set -e in it, thus inheriting set -e, and then when tests failed, it bailed out immediately instead of continuing as was intended.
Comment on attachment 8955686 [details] [diff] [review]
Prevent set -e from leaking into calling scripts

Review of attachment 8955686 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for catching this issue :)
I learning some Shell scripting too, I did not knew that set could be scoped that way.

> If I remember correctly, the issue ended up being that try turns off ASLR?

Correct.
Attachment #8955686 - Flags: review?(nicolas.b.pierron) → review+
Pushed by sfink@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8799608e5f0b
Prevent set -e from leaking into calling scripts, r=nbp
https://hg.mozilla.org/mozilla-central/rev/8799608e5f0b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.