Closed Bug 1442887 Opened 2 years ago Closed 2 years ago

Fix position of #clearDataSettings button

Categories

(Firefox :: Preferences, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 61
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- wontfix
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- wontfix
firefox61 --- fixed

People

(Reporter: magicp.jp, Assigned: johannh)

References

Details

(Keywords: regression, Whiteboard: [storage-v2])

Attachments

(2 files)

Steps to reproduce:
1. Launch Nightly
2. Go to about:preferences#privacy > History
3. Change history mode from "Remember history" to "Use custom settings for history"

Actual results
#clearDataSettings button is not on the right.

Expected results
#clearDataSettings button is on the right.

Regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=36be9b83bcc9928cd06ebdd3402939e152582fff&tochange=ce6adae0faa1a40db9e0015d880c3d086f755d23
Blocks: 1436568
Has Regression Range: --- → yes
Has STR: --- → yes
See Also: → 1442993
Whiteboard: [storage-v2][triage]
Priority: -- → P2
Whiteboard: [storage-v2][triage] → [storage-v2]
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Priority: P2 → P1
Keywords: regression
Comment on attachment 8967674 [details]
Bug 1442887 - Align the #clearDataSettings button in about:preferences to the very right.

https://reviewboard.mozilla.org/r/236404/#review242238

Looks good, thanks!
Attachment #8967674 - Flags: review?(jaws) → review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/70343258ed74
Align the #clearDataSettings button in about:preferences to the very right. r=jaws
Backed out for failing browser chrome at browser/components/preferences/in-content/tests/browser_search_subdialogs_within_preferences_site_data.js

Push that started the failures:  https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=70343258ed74a10d9810774e92f5fe2b9c0918be

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=173556081&repo=autoland&lineNumber=6232

Backout: https://hg.mozilla.org/integration/autoland/rev/4e991b394cdf5be84854aeb024fe592f41b9b42e
Flags: needinfo?(jhofmann)
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5d6c7b12169a
Align the #clearDataSettings button in about:preferences to the very right. r=jaws
https://hg.mozilla.org/mozilla-central/rev/5d6c7b12169a
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Flags: needinfo?(jhofmann)
This looks like an annoying visual regression to ship in Fx60. What are your thoughts about nominating this for Fx60 backport still? We build the first RC of it today.
Flags: needinfo?(jaws)
I personally wouldn't consider this annoying enough to backport to ESR, but it shouldn't be a big deal either...
Doesn't graft cleanly to 60 anyway. Let's let it ride the trains then.
Flags: needinfo?(jaws)
QA Whiteboard: [good first verify]
I have reproduced this bug with Nightly 60.0a1 (2018-03-03)on Windows 10, 64 Bit!
This bug's fix is verified with latest Beta!

Build ID 	20180528091514
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
QA Whiteboard: [good first verify] → [good first verify] [bugday-20180613]
You need to log in before you can comment on or make changes to this bug.