Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 144290 - Mozilla ignores mailcap program arguments,
: Mozilla ignores mailcap program arguments,
Status: VERIFIED DUPLICATE of bug 52441
Product: Core Graveyard
Classification: Graveyard
Component: File Handling (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Bill Law
: sairuh (rarely reading bugmail)
Depends on:
  Show dependency treegraph
Reported: 2002-05-13 16:17 PDT by Jason Crosswhite
Modified: 2016-06-22 12:16 PDT (History)
0 users
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Description Jason Crosswhite 2002-05-13 16:17:01 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051009

While trying to configure Code Weavers Crossover plugins, I discovered a mailcap
entry similar to the following won't work:

video/x-dv;/opt/crossover/bin/ "C:/PROG~FBU/QUIC~EA4/QuickTimePlayer.exe"
"%s";  \
    test=test "$DISPLAY" != ""; \

Any command with an argument merely executes the command and the file name.  No
arguments are passed. Even "echo %s > /dev/null" doesn't work.

As a workaround, you can write a script for every mailcap entry that includes
the correct arguments to the program given the filename.  However, with the
typical number of entries in a mailcap, this is very suboptimal.

Reproducible: Always
Steps to Reproduce:
1.make an entry in /etc/mailcap: "application/msword; echo "the file is %s";"
(or anything else that isn't just %s) the current dir, type "touch test.doc"
3.start Mozilla with "mozilla &"
4.go to "File->Open File...
5.Choose "all files" under "files of type" dropdown
6.Select "test.doc", click "open"
7.Select "open the file with echo"
8."whateverdir/test.doc" is printed everytime.  replace echo with whatever you
want, and it always ignores the arguments

Actual Results:  "/home/jason/test.doc" was echoed to my terminal

Expected Results:  "the file is test.doc" should have been echoed to my terminal

While searching the net to find an answer, I came upon several instances of the
"x-mozilla-flag" mailcap option, but I can find no documentation listing all the
options and what they mean.  Might be nice to add that somewhere.
Comment 1 timeless 2002-05-13 18:59:28 PDT

*** This bug has been marked as a duplicate of 52441 ***
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2002-05-13 19:03:49 PDT
This is actually bug 83305, but marking verified in the interests of minimizing

I hope to get to implementing this sometime this July.

Note You need to log in before you can comment on or make changes to this bug.