Closed Bug 1442915 Opened 5 years ago Closed 5 years ago

Transform animation goes wild.

Categories

(Core :: Graphics, defect)

60 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- wontfix
firefox59 --- wontfix
firefox60 --- fixed

People

(Reporter: emilio, Assigned: mattwoodrow)

References

(Depends on 1 open bug, )

Details

(Keywords: regression)

Attachments

(4 files)

I found this on the wild in http://montereybar.com/. Reduced test-case coming.

With WR enabled the back face of the transformed object just doesn't show, but with WR disabled the transform animation flickers as crazy.

Will file a separate bug for webrender.

Testcase incoming.
Attached file testcase.html
Note that this is on Linux, but HW acceleration force-enabled. Let me try with it disabled and I'll report back.
(In reply to Emilio Cobos Álvarez [:emilio] from comment #2)
> Note that this is on Linux, but HW acceleration force-enabled. Let me try
> with it disabled and I'll report back.

With it disabled doesn't look good either, though arguably it's different. In any case, it still flickers.
See Also: → 1442916
Attached video 2018-03-03_21-01-45.mp4
Nightly 60 x64 20180303100406 de_DE @ Debian Testing (KDE, Radeon RX480)
basic and opengl compositing look the same.
No issue at 100%, but flickering at 80% zoom for example.
Attached video 2018-03-03_21-06-35.mp4
> Created attachment 8955810 [details]
> testcase.html

always broken
1. Regression on 2017-06-14: It was just invisible when hovering it.
mozregression --good 2017-02-01 --bad 2018-03-03 --pref layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8955810"
> 13:25.28 INFO: Last good revision: 958d2a5d10091401fd5e900e8e063d21940c137e
> 13:25.28 INFO: First bad revision: 7f894f791cdf170d788507d0eff30024ce699523
> 13:25.28 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=958d2a5d10091401fd5e900e8e063d21940c137e&tochange=7f894f791cdf170d788507d0eff30024ce699523

mozregression --repo autoland --launch d0f17a12ae61 --pref layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8955810"
good

955bb796fd65 good
114fb8a5f56c good
b266a8d8fd59 good
68932b1a5b71 bad: bug 1361970 caused a lot of regressions. I don't know if this is the regressing bug, but I assume.
* most are fixed on 2017-06-22,
* bug 1378455 was fixed on 2017-08-01
* bug 1423528 was fixed on 2018-02-21

2. Searching for the moment when it was visible again when hovering it (but with flickering):
mozregression --find-fix --bad 2017-06-14 --good 2017-09-03 --pref layout.display-list.retain:false startup.homepage_welcome_url:"https://bugzilla.mozilla.org/attachment.cgi?id=8955810"
> 9:08.64 INFO: First good revision: 78676939447ffd59eb7a265fbd78a384d30136ec
> 9:08.64 INFO: Last bad revision: 1704a6f949aff1d8101061645ede31ca96b572f8
> 9:08.64 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1704a6f949aff1d8101061645ede31ca96b572f8&tochange=78676939447ffd59eb7a265fbd78a384d30136ec

Made it visible again, but with flickering:
> 78676939447f	Matt Woodrow — Bug 1381753 - Recompute visible regions for ContainerLayers without intermediate surfaces when needed for invalidation. r=mstange
This fixed a regression (bug 1381753) caused by a patch which wanted to fix a regression (bug 1373479) which was caused by bug 1361970. So my assumption seems to be valid.
Blocks: 1361970
Has Regression Range: --- → yes
Depends on: 1381753
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Version: unspecified → 60 Branch
Could you have a look please? Mozregression points to your changes.
Flags: needinfo?(matt.woodrow)
Depends on: 1248828
Flags: needinfo?(matt.woodrow)
Attached patch dont-use-visibleSplinter Review
ComputeEffectiveTransforms runs before we recompute the shadow visible regions (as it needs to, since we need to know what intermediate surfaces exist before we can compute what's visible on them).

Given that, trying to use the visible region from here gives bad results.
Assignee: nobody → matt.woodrow
Attachment #8955969 - Flags: review?(mstange)
Attachment #8955969 - Flags: review?(mstange) → review+
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cc36ff7b9f58
Don't use shadow visible region in DefaultComputeEffectiveTransforms since it might not be computed yet. r=mstange
https://hg.mozilla.org/mozilla-central/rev/cc36ff7b9f58
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.