Closed Bug 1442960 Opened 2 years ago Closed Last year

Remove workaround for bug 1438504 after bug 1439875

Categories

(Firefox :: Tabbed Browser, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 63
Tracking Status
firefox63 --- fixed

People

(Reporter: dao, Assigned: dao)

References

Details

Attachments

(1 file)

See bug 1439875 comment 26:

> > > Now we're starting to size the window before layout, while before the
> > > constraints were applied while the window was 1x1.
> > 
> > Does this mean we won't anymore have to deal with the window being sized 1x1
> > initially? Because I just recently added a workaround for that in bug
> > 1438504.
> 
> Yes, this bug will remove the workaround for that also in our tests, like
> https://searchfox.org/mozilla-central/rev/
> bd05e3853c6e982e2a35c1cc404b987b2bc914d6/browser/base/content/test/
> performance/browser_windowopen_flicker.js#77. The issue is that now I need
> to update the test, which is what I'm doing now.
Priority: -- → P3
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Comment on attachment 8989840 [details]
Bug 1442960 - Remove workaround for bug 1438504.

https://reviewboard.mozilla.org/r/254804/#review262266
Attachment #8989840 - Flags: review?(bgrinstead) → review+
https://hg.mozilla.org/mozilla-central/rev/0d969c0e0f39
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
You need to log in before you can comment on or make changes to this bug.