Remove bookmarks and history sync ID and last sync downgrade logic

RESOLVED FIXED in Firefox 66

Status

()

enhancement
P1
normal
RESOLVED FIXED
Last year
6 months ago

People

(Reporter: lina, Assigned: lina)

Tracking

unspecified
Firefox 66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(1 attachment)

Bug 1199077 writes the sync ID and last sync to Places and prefs, to support downgrading to earlier channels, and so that upgrading doesn't trigger a full sync. We can remove this logic after a few releases.
Priority: -- → P3
Blocks: 1454557
Assignee

Updated

6 months ago
Duplicate of this bug: 1517453
Assignee

Updated

6 months ago
No longer blocks: 1454557
Assignee

Updated

6 months ago
Duplicate of this bug: 1454557
Assignee

Comment 4

6 months ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=9e8ac28434a512fc759dd2cb349821fc120506d5
Assignee: nobody → lina
Status: NEW → ASSIGNED
Priority: P3 → P1

Comment 5

6 months ago
Pushed by kcambridge@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/be38e913927a
Remove sync ID pref migration for bookmarks and history. r=markh

Comment 6

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/be38e913927a
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
You need to log in before you can comment on or make changes to this bug.